I am on the latest version of Windows 10, running with SWI-Prolog 7.6.4, and trying to get JPL (Java <->Prolog) running for a school project. I've not had to deal with path issues much but I have done my best to understand the problem.

I've added the necessary import statements to my java class file, and the necessary environment variables to my system as per the page here: https://jpl7.org/DeploymentWindows

However it still does not show up as a valid java package.

I've just realized as I write this that maybe I need to reboot. I will try that after posting this.

EDIT: Rebooting did nothing to help. Please, this is rather urgent.

Latest W10? There's some issue with associations. No, I can't tell if this is your issue but I found myself back at the command line to fix it.
https://www.cnet.com/forums/discussions/windows-10-file-associations-text-files/

"Use the ASSOC then the FTYPE command in an elevated command prompt. Read how at https://superuser.com/questions/841497/windows-open-with-application-not-appearing-as-an-option/1020255

Using this I changed my text editor to Notepad++. Screen shot follows."

as1.PNG

Since this is a rather recent W10 glitch, my bet is you'll have to ask the source for what to do.

commented: What the heck are you talking about? This has nothing to do with filetypes. +0

Your post lead me to think you dealt with path issues. Then you wrote about the latest Windows 10. Another programmer ran into an association issue where his choice of editor would not stick. This problem also extends to woes in systems like JPL.

If my sharing about a current bug that is causing developer headaches is not acceptable then just say so.

I didn't write one sentence about Java paths because, it's been done so many times before. I'm going to share other than that.

The PHP and C/C++ NetBeans bundles only require the Java Runtime Environment (JRE) 7 or 8 to be installed and run. JDK 7 or 8 is required if you are planning to use any of the Java features. JDK 7 Update 6 (or newer) is required to use JavaFX 2.2 (or newer) features in NetBeans IDE 8.1[Click Here](The PHP and C/C++ NetBeans bundles only require the Java Runtime Environment (JRE) 7 or 8 to be installed and run. JDK 7 or 8 is required if you are planning to use any of the Java features. JDK 7 Update 6 (or newer) is required to use JavaFX 2.2 (or newer) features in NetBeans IDE 8.1)

commented: I too have run into folk that install some Java app but forgot to install Java itself. +15