I have changed the Path Environment Variable for Windows Command Prompt to:

C:\j2sdk1.4.2_04\bin

so why, when I try to run javac while in the code folder directory, do I still get the error message

"javac is not recognized as an internal..."

I was forced to put the path info in at the command prompt before the .java file would compile.

Help.

Re: help me set path 80 80

Greetings.
Errr, do you mean that you have set the path in the System Properties?
With Variable: Path
and Value: c:/j2sdk1.4.2_04/bin ?

Re: help me set path 80 80

yes, thats what I mean, with the slashes as I have written them

Re: help me set path 80 80

help with the path for servlets

Re: help me set path 80 80

well i got my path working in any case

Re: help me set path 80 80

First try to locate te bin folder from the windows explorer, and then copy the path to ur environment variable, which you can get by right clicking on My Computer Icon and then to Advanced Tab and then to Environment Variable...
But i think if you install the jre or jdk for jsdk it by default reallocates ur path to c:\\Program Files\Java\j2sdk1.4.2_04\bin

check this out...

Regards...

I have changed the Path Environment Variable for Windows Command Prompt to:

C:\j2sdk1.4.2_04\bin

so why, when I try to run javac while in the code folder directory, do I still get the error message

"javac is not recognized as an internal..."

I was forced to put the path info in at the command prompt before the .java file would compile.

Help.

Re: help me set path 80 80

help with the path for servlets

I'm runnning Tomcat Appache 5.5.15 wth JAVA 1.5.06. To get servlets run on my laptop I only copied and past servlet-api.jar & jsp-api.jar into following directory

C:\Program Files\Java\jdk1.5.0_06\jre\lib\ext

which is where java is installed

you can find this jar files in tomcat as follow

C:\Tomcat 5.5\common\lib

and to setting path for java, don't forget put on end of path semicolum " ; " or some pc refuse to work with java

Re: help me set path 80 80

hi....im working with tomcat... to run servlets....i cant execute the javac command in dos ....what do i do??? java is installed...i even gave the path to where its installed...i even changed yhe system properties... but it says javac is not recognised as internal and external command...

Re: help me set path 80 80

Start your own thread, but that "error" is always that the path is not set (not classpath, path).

Re: help me set path 80 80

Just go at command prompt and check whether ur jdk is in programme files, if it is programe
file then set path
c:\set path=C:\programe files\j2sdk1.4.2_04\bin;%path%;
or if not in prog files then
c:\set path=C:\j2sdk1.4.2_04\bin;%path%;

Re: help me set path 80 80

how to set path? after typng the program is not getting executed. it is showing tat javac is not recognized so please tell wat to do

Re: help me set path 80 80

how to set path? after typng the program is not getting executed. it is showing tat javac is not recognized so please tell wat to do

First post here explain how to install Java and how to set PATH

Be a part of the DaniWeb community

We're a friendly, industry-focused community of 1.19 million developers, IT pros, digital marketers, and technology enthusiasts learning and sharing knowledge.