0

Hi,


Maybe this thread must be in unix forum, but there are no server's subforum, so I start this thread here.

this is first time I'm installing GeoIP.

yum install geoip

- successfully installed version 1.4.4-2.fc8


But I need it to work on php, so I tried:

pecl install geoip

and got some errors:
................

configure: WARNING: You will need re2c 0.12.0 or later if you want to regenerate PHP parsers.
checking for gawk... gawk
checking for geoip support... yes, shared
checking for geoip files in default path... not found
configure: error: Please reinstall the geoip distribution
ERROR: `/tmp/pear/download/geoip-1.0.3/configure' failed

I installed re2c-0.13.1 version and now there are no this warning: WARNING: You will need re2c 0.12.0 or later if you want to regenerate PHP parsers.

I tried to google, but this not helped me this time. I don't know what to do now.

1
Contributor
1
Reply
4
Views
8 Years
Discussion Span
Last Post by xoxbet
0

Problem solved by installing geoip-devel:

yum install geoip-devel
This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.