The project specs requires that I send some data to a remote server, where records based on the data that I send will be searched from a MySQL db, and returned to the caller. I developed a class that resides in the remote Web server with MySQL. The local php pages includes that class, sends the data via the member function of the class, and receive the result. The remote Web Server is Apache 2.2

But when I am trying to include the file with a

require_once ("http://www.remoteserver.com/Remote/Remoteclass.php");

I am getting the error: URL file-access is disabled in the server configuration. For the directory that has the file, I have specified "Allow from all" in the httpd.conf file.

How do I get access to the remote file ? I think this is most probably an Apache issue, but I am not sure what changes are required and where ? Do I have to specify anything in the php.ini file ? I have checked the "allow_url_fopen" setting in the php.ini file and it is set to on.

If i can try to figure out this correctly, you have to have both permissions from the current server AND the remote server. One should be allowed to retrieve from another server and the other to accept and send to remote server but I'm not sure.

I am testing this now on a single machine, using 2 different sites (folders under htdocs) and the server is same. I also checked that the allow_url_include setting is "on" in php.ini. I am getting the error:
failed to open stream: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.
Failed opening required 'http://localhost:8080/Remote/RemDColl.php' (include_path='.;c:\php\includes; http://localhost:8080/Remote/;')

Any idea of what other settings I have to check ?

This article has been dead for over six months. Start a new discussion instead.