0

I have a web application that I create that works great on my computer. I have an account with 1and1, so I uploaded the database and the files.

I am also using Linq to SQL, so I have a dbml file. But, everytime I run a function that needs the database, I get a file not found error.

I have doubts that it has to do something with Web.config file. This is the snippet for the connection part

<add name="dbEntities" connectionString="metadata=res://*/common.dbModel.csdl|res://*/common.dbModel.ssdl|res://*/common.dbModel.msl;provider=System.Data.SqlClient;provider connection string=&quot;Data Source=****.net,1433;Initial Catalog=db****;Persist Security Info=True;User ID=dbo*****;MultipleActiveResultSets=True&quot;" providerName="System.Data.EntityClient" />

<add name="dbRxReliefConnectionString" connectionString="Data Source=*****.net,1433;Initial Catalog=db*****;Persist Security Info=True;User ID=dbo******;Password=*******" providerName="System.Data.SqlClient" />
4
Contributors
9
Replies
16
Views
7 Years
Discussion Span
Last Post by asif671
0

Did you check whether the datasource is based on SQL Instance (server/SQLEXPRESS) ?

I know that it's an MSSQL database. How do I check if the instance is server/SQLEXPRESS?

0

Your hosting provider is supposed to provide the server instance.
Would be useful if you could provide the error with more detail and your sample code for debugging.

0

Here is more detail

I was given this connection string:

Provider=sqloledb;Data Source=*****.net,1433;Initial Catalog=db*********;User Id=dbo********;Password=*****;

And it is an MS SQL database.

So, I changed the Web.config files to this:

<add name="dbEntities" connectionString="metadata=res://*/common.dbModel.csdl|res://*/common.dbModel.ssdl|res://*/common.dbModel.msl;provider=System.Data.SqlClient;provider connection string="Data Source=***.net,1433;Initial Catalog=db*******;Persist Security Info=True;User ID=dbo*******;MultipleActiveResultSets=True""providerName="System.Data.EntityClient" />

<add name="dbSiteConnectionString" connectionString="Data Source=********.net,1433;Initial Catalog=db*********;Persist Security Info=True;User ID=dbo*********;Password=*****" providerName="System.Data.SqlClient" />

It's not working! Please help!

Thanks!

Edited by all4peace: n/a

0

Hi everyone,

Hmmmm... This is really bothering me...

So, I went to 1and1.com troubleshooting and found this code. I ran it with my connection string:

server=*****.net,1433; initial catalog=db*****;uid=dbo*****;pwd=*****

It actually worked!!! So, I said let me go back to my original code and see what's going on. So, I went to the dbml file and found this line:

<Connection Mode="WebSettings" ConnectionString="****" 
SettingsObjectName="System.Configuration.ConfigurationManager.ConnectionStrings" SettingsPropertyName="<property-name>"
Provider="System.Data.SqlClient" />

The WebSettings means it will look into Web.config. I said, screw it! I'll just put the connection string there. (It works in my home computer)

<Connection Mode="ConnectionString" ConnectionString="*****" Provider="System.Data.SqlClient" />

Note: The connection string is exactly the same one that is used above! IT STILL DOESN'T WORK IN MY WEBSITE... :'( :@

Please help me here! Thanks,

0

Hello,

I'm in the exactly situation than you, I know this post is a bit old but I would appreciate so much if you can help me. How did you solved it? I'm becoming to be afraid that 1and1 doesn't support Entity Framework.

Thanks a lot

0

Hi dangior,

I had to use a different method other than Linq. The good news is that 1and1 now supports LINQ - may be my complaints worked.

Regards,
all4peace

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.