0

Hi!
I'm trying to install a php product that requires ioncube loader. I have followed several guides (they are all the same) for how to install it.

Running ioncube-loader-helper.php tells me the location of the php.ini file. The server has a set of ioncube loaders, and the helper tells me i need version 5.2, which is there. There are no zend extension lines in php.ini, so at the very bottom of the file i insert the line as it says.

Ths is the line:
zend_extension=/usr/local/lib/ioncube/ioncube_loader_lin_5.2.so
i also tried:
zend_extension="/usr/local/lib/ioncube/ioncube_loader_lin_5.2.so"

I restarted apache2 each time. Finally I delibaretly tried to cause an error by inserting some random characters in php.ini and restarted apache2, and it didn't even react. Since ioncube-loader-helper found the same php.ini file as I was editing, I thought the file must be correct. Any ideas?

php version: 5.2.6-2ubuntu4.5

3
Contributors
4
Replies
5
Views
7 Years
Discussion Span
Last Post by ribot
0

Try restarting your machine. I find (On Windows, though, not Ubuntu) that even if I restart apache, the php.ini doesn't update until after a restart.

0

I just had a very similar problem. It turned out that someone had tried to install the x64 version of ioncube loader on a 32-bit host. When I installed the 32-bit version, the loader loaded OK.

0

yes it was the same problem for me...the thing to do was to check the apache log, and there it would tell the problem.

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.