0

Hello, I have googled the similar problem that many people are facing but I still can't solve mine.

I'm trying to visit the ASP.NET Web Site Administration Tool at http://localhost:49274/asp.netwebadminfiles

The page shows me the error "An error was encountered. Please return to the previous page and try again."

Some says it has to do with web.config file, I'm new to ASP.NET, here is my web.config file

<?xml version="1.0" encoding="utf-8"?>
<!--
  For more information on how to configure your ASP.NET application, please visit
  [url]http://go.microsoft.com/fwlink/?LinkId=152368[/url]
  -->
<configuration>
  <system.web>
    <compilation debug="true" targetFramework="4.0">
      <assemblies>
        <add assembly="System.Web.Abstractions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
        <add assembly="System.Web.Routing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
        <add assembly="System.Web.Mvc, Version=2.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
        <add assembly="System.Data.Entity, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" />
      </assemblies>
    </compilation>
    <authentication mode="Forms">
      <forms loginUrl="~/Account/LogOn" timeout="2880" />
    </authentication>
    <pages>
      <namespaces>
        <add namespace="System.Web.Mvc" />
        <add namespace="System.Web.Mvc.Ajax" />
        <add namespace="System.Web.Mvc.Html" />
        <add namespace="System.Web.Routing" />
      </namespaces>
    </pages>
  </system.web>
  <system.webServer>
    <validation validateIntegratedModeConfiguration="false" />
    <modules runAllManagedModulesForAllRequests="true" />
  </system.webServer>
  <runtime>
    <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
      <dependentAssembly>
        <assemblyIdentity name="System.Web.Mvc" publicKeyToken="31bf3856ad364e35" />
        <bindingRedirect oldVersion="1.0.0.0" newVersion="2.0.0.0" />
      </dependentAssembly>
    </assemblyBinding>
  </runtime>
  <connectionStrings>
    <add name="MvcMusicStoreEntities" connectionString="metadata=res://*/Models.StoreDB.csdl|res://*/Models.StoreDB.ssdl|res://*/Models.StoreDB.msl;provider=System.Data.SqlClient;provider connection string=&quot;Data Source=.\SQLEXPRESS;AttachDbFilename=|DataDirectory|\MvcMusicStore.mdf;Integrated Security=True;User Instance=True;MultipleActiveResultSets=True&quot;" providerName="System.Data.EntityClient" />
  </connectionStrings>
</configuration>

I have saved the project under the default VS directory

C:\Users\kisman\Documents\Visual Studio 2010\Projects\MvcMusicStore

I'm using:
Visual Studio 2010
SQL Server 2008
Windows 7

Edited by esia168: n/a

1
Contributor
1
Reply
4
Views
7 Years
Discussion Span
Last Post by esia168
1

Finally, after much frustration, it's solved.

The solution is the project path must not have weird character like #% or spaces, I renamed the project path to, with underscore for space
C:\Users\kisman\Documents\Visual_Studio_2010\Projects\MvcMusicStore

Edited by esia168: n/a

Votes + Comments
Thanks. It sorted me out. Why haven't they fixed it?
This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.