0

I have problem with my mini blog since 2 days until now http://blog.soccerass.com/

Here the latest error log --> [Tue Aug 03 03:51:43 2010] [crit] [client 87.250.254.243] (13)Permission denied: /home/socc*****/public_html/.htaccess pcfg_openfile: unable to check htaccess file, ensure it is readable

I have 2 domains called soccerpropick.com and soccerass.com both placed in one host. First domain redirect to second domain and redirect to my blog.

I have wordpress installed and on latest update I just post article update and approve positive comments. After approve comments, the problem show up and give me 403 Forbidden (you can check my blog).

My previous problem on my blog folder and solved. I install frontpage-extension in /home/socc*****/public_html/blog and NOW I have try to install frontpage-extension to my first domain home/socc*****/public_html/ but not solve my problem.

Please help me what should I do :-/

3
Contributors
10
Replies
11
Views
7 Years
Discussion Span
Last Post by jens86
0

You need to look at the actual permissions and ownership of the .htaccess file. Needs to be readable for internet probably something like:

-rw-r--r--   1 bob apache       316 2010-07-14 04:16 .htaccess
0

You need to look at the actual permissions and ownership of the .htaccess file. Needs to be readable for internet probably something like:

-rw-r--r--   1 bob apache       316 2010-07-14 04:16 .htaccess

What should I do if htaccess like this ;

RewriteEngine on

RewriteCond %{HTTP_HOST} ^soccerass.com$ [OR]
RewriteCond %{HTTP_HOST} ^www.soccerass.com$
RewriteRule ^/?$ "http\:\/\/blog\.soccerass\.com" [R=301,L]

RewriteCond %{HTTP_HOST} ^soccerpropick.com$ [OR]
RewriteCond %{HTTP_HOST} ^www.soccerpropick.com$
RewriteRule ^/?$ "http\:\/\/www\.soccerass\.com" [R=301,L]

RewriteCond %{HTTP_REFERER} !^http://blog.soccerass.com/.*$      [NC]
RewriteCond %{HTTP_REFERER} !^http://blog.soccerass.com$      [NC]
RewriteCond %{HTTP_REFERER} !^http://soccerass.com/.*$      [NC]
RewriteCond %{HTTP_REFERER} !^http://soccerass.com$      [NC]
RewriteCond %{HTTP_REFERER} !^http://soccerpropick.com/.*$      [NC]
RewriteCond %{HTTP_REFERER} !^http://soccerpropick.com$      [NC]
RewriteCond %{HTTP_REFERER} !^http://www.blog.soccerass.com/.*$      [NC]
RewriteCond %{HTTP_REFERER} !^http://www.blog.soccerass.com$      [NC]
RewriteCond %{HTTP_REFERER} !^http://www.soccerass.com/.*$      [NC]
RewriteCond %{HTTP_REFERER} !^http://www.soccerass.com$      [NC]
RewriteCond %{HTTP_REFERER} !^http://www.soccerpropick.com/.*$      [NC]
RewriteCond %{HTTP_REFERER} !^http://www.soccerpropick.com$      [NC]
RewriteRule .*\.(jpg|jpeg|gif|png|bmp)$ - [F,NC]

I have use cpanel do this redirect or whatever
Let me know how to get it work ?

Edited by jens86: n/a

0

Please read on this - AllowoverideAll to appear in virtual host file
This statement is one of the .htaccess issues because your .htaccess file is very much clear.

Edited by sourcebits: n/a

0

Please read on this - AllowoverideAll to appear in virtual host file
This statement is one of the .htaccess issues because your .htaccess file is very much clear.

PLease let me know step by step :$
I do not understand with "AllowoverideAll"

0

Ok based on the error message the problem is not the content of your file but permission for apache to read it to begin with. If you check the file ownership and read write permissions and compare it to your web pages permissions I believe you will see the problem.

0

Why all people here not posted step-by-step guide ?

Please let me know

0

Well it is hard to provide a step by step guide when we do not know your OS, how your access your site, if you are on a shared or private server. Also remember this is a service we do without compensation so you can ask but you may not get what you ask for.
On linux from the command prompt you type

ls -la

and compare the permissions to the ones I originally provided.

0

In addtion to other steps you will take to make .htaccess works
Please ensure that this directive has AllowOverride All as it apears below.
<Directory /var/www/>
Options Indexes FollowSymLinks MultiViews
AllowOverride All
Order allow,deny
allow from all
</Directory>

0

Well it is hard to provide a step by step guide when we do not know your OS, how your access your site, if you are on a shared or private server. Also remember this is a service we do without compensation so you can ask but you may not get what you ask for.
On linux from the command prompt you type

ls -la

and compare the permissions to the ones I originally provided.

This is forum,, everyone have right to ask :) and other people share what they know IMO

OS windows
Cpanel / FTP
Shared server <-- they have told me that they can not handle my big blog and still not solved :(

need your guide

0

In addtion to other steps you will take to make .htaccess works
Please ensure that this directive has AllowOverride All as it apears below.
<Directory /var/www/>
Options Indexes FollowSymLinks MultiViews
AllowOverride All
Order allow,deny
allow from all
</Directory>

where I could find this file ?

:$

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.