0

Hi,

I am trying to install PHPUnit and having problems. I get many errors:

# pear install phpunit/PHPUnit
phpunit/PHPUnit can optionally use PHP extension "dbus"
phpunit/PHP_CodeCoverage can optionally use PHP extension "xdebug" (version >= 2
.0.5)
downloading PHPUnit-3.5.13.tgz ...
Starting to download PHPUnit-3.5.13.tgz (118,553 bytes)
..........................done: 118,553 bytes
could not extract the package.xml file from "E:\Program Files\xampp\tmp\PHPUnit-
3.5.13.tgz" Unable to create directory 'E:/Program/tmp9898.tmp'
Unable to create path for E:/Program/tmp9898.tmp/package.xml
Download of "phpunit/PHPUnit" succeeded, but it is not a valid package archive
Error: cannot download "phpunit/PHPUnit"
downloading DbUnit-1.0.1.tgz ...
Starting to download DbUnit-1.0.1.tgz (39,055 bytes)
...done: 39,055 bytes
could not extract the package.xml file from "E:\Program Files\xampp\tmp\DbUnit-1
.0.1.tgz" Unable to create directory 'E:/Program/tmp9B0A.tmp'
Unable to create path for E:/Program/tmp9B0A.tmp/package.xml
Download of "phpunit/DbUnit" succeeded, but it is not a valid package archive
Error: cannot download "phpunit/DbUnit"
downloading File_Iterator-1.2.6.tgz ...
Starting to download File_Iterator-1.2.6.tgz (3,439 bytes)
...done: 3,439 bytes
could not extract the package.xml file from "E:\Program Files\xampp\tmp\File_Ite
rator-1.2.6.tgz" Unable to create directory 'E:/Program/tmp9BC6.tmp'
Unable to create path for E:/Program/tmp9BC6.tmp/package.xml
Download of "phpunit/File_Iterator" succeeded, but it is not a valid package arc
hive
Error: cannot download "phpunit/File_Iterator"
downloading PHP_CodeCoverage-1.0.4.tgz ...
Starting to download PHP_CodeCoverage-1.0.4.tgz (115,029 bytes)
...done: 115,029 bytes
could not extract the package.xml file from "E:\Program Files\xampp\tmp\PHP_Code
Coverage-1.0.4.tgz" Unable to create directory 'E:/Program/tmpA06B.tmp'
Unable to create path for E:/Program/tmpA06B.tmp/package.xml
Download of "phpunit/PHP_CodeCoverage" succeeded, but it is not a valid package
archive
Error: cannot download "phpunit/PHP_CodeCoverage"
downloading PHPUnit_MockObject-1.0.8.tgz ...
Starting to download PHPUnit_MockObject-1.0.8.tgz (18,199 bytes)
...done: 18,199 bytes
could not extract the package.xml file from "E:\Program Files\xampp\tmp\PHPUnit_
MockObject-1.0.8.tgz" Unable to create directory 'E:/Program/tmpA202.tmp'
Unable to create path for E:/Program/tmpA202.tmp/package.xml
Download of "phpunit/PHPUnit_MockObject" succeeded, but it is not a valid packag
e archive
Error: cannot download "phpunit/PHPUnit_MockObject"
downloading PHPUnit_Selenium-1.0.2.tgz ...
Starting to download PHPUnit_Selenium-1.0.2.tgz (16,412 bytes)
...done: 16,412 bytes
could not extract the package.xml file from "E:\Program Files\xampp\tmp\PHPUnit_
Selenium-1.0.2.tgz" Unable to create directory 'E:/Program/tmpA36A.tmp'
Unable to create path for E:/Program/tmpA36A.tmp/package.xml
Download of "phpunit/PHPUnit_Selenium" succeeded, but it is not a valid package
archive
Error: cannot download "phpunit/PHPUnit_Selenium"
downloading PHP_TokenStream-1.0.1.tgz ...
Starting to download PHP_TokenStream-1.0.1.tgz (7,250 bytes)
...done: 7,250 bytes
could not extract the package.xml file from "E:\Program Files\xampp\tmp\PHP_Toke
nStream-1.0.1.tgz" Unable to create directory 'E:/Program/tmpA475.tmp'
Unable to create path for E:/Program/tmpA475.tmp/package.xml
Download of "phpunit/PHP_TokenStream" succeeded, but it is not a valid package a
rchive
Error: cannot download "phpunit/PHP_TokenStream"
Download failed
install failed

How can there be so much errors? There is something completely wrong but I don't know how to solve, can you help me?

1
Contributor
1
Reply
2
Views
6 Years
Discussion Span
Last Post by McLaren
This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.