My program is a simple client database that holds information on tenants. Each tenant has a LONGBLOB column called 'notes' to hold updated information on them.

For tenants that have a long list of notes, when the form is submitted the site actually goes to a 404, so their profile never gets updated.

Is there a HTTP limit to POST/GET characters that can be sent? I cannot figure out if this problem is being caused by PHP or IIS, as this has never happened before.

Any help is appreciated, sorry if my explanation is bad.

Recommended Answers

Don't you use POST for this? A GET request used to be very limited. It depends on your IIS version.

Jump to Post

All 6 Replies

My post_max_size is already set to 80m. I'm not uploading a file, just running a mysql UPDATE query with a large amount of text. Once the text hits a certain limit, the form submission goes to a 404 page.

New tenants with little to no "notes" never have this problem. The issue only occurs with tenants with a large amount of notes that are being added onto.

Okay. Is there something in the notes that can trigger a query failure ?

I suggest you implement some logging, so you can determine when/how your code fails.

Also, what version of IIS are you running ?

It never gets to the query. It's as if the request overflows, and sputters into a 404 page.

I cannot echo/print out my query. When the page does 404 Error, this is an example of a URL:

http://.....query.php?formname=edit_user&id=2115&building=1010+Waveland&order_received=2012-01-05&order_received_dp=1&order_received_year_start=2000&order_received_year_end=2015&order_received_mon=&order_received_da1=1210654800&order_received_da2=1425189600&order_received_sna=1&order_received_aut=&order_received_frm=&order_received_tar=&order_received_inp=&order_received_fmt=j+F+Y&order_received_dis=&order_received_pr1=&order_received_pr2=&order_received_prv=&order_received_pth=calendar%2Fcalendar%2F&order_received_spd=[]&order_received_spt=0&order_received_spr=&appointment_date=0000-00-00&appointment_date_dp=1&appointment_date_year_start=2000&appointment_date_year_end=2015&appointment_date_mon=&appointment_date_da1=1210654800&appointment_date_da2=1425189600&appointment_date_sna=1&appointment_date_aut=&appointment_date_frm=&appointment_date_tar=&appointment_date_inp=&appointment_date_fmt=j+F+Y&appointment_date_dis=&appointment_date_pr1=&appointment_date_pr2=&appointment_date_prv=&appointment_date_pth=calendar%2Fcalendar%2F&appointment_date_spd=[]&appointment_date_spt=0&appointment_date_spr=&tenant_name=Lorax+TEST&tenant_email=butisnecessary&building_address=1010+Waveland&unit=600&time1=Not+Set&time2=Not+Set&phone=7738705442&receiver_type1=Standard&rid1=&ac1=&receiver_type2=None&rid2=&ac2=&receiver_type3=None&rid3=&ac3=&receiver_type4=None&rid4=&ac4=&status=NTC&paid=Yes&amount=&notes=Lorem+ipsum+dolor+sit+amet%2C+consectetur+adipiscing+elit.+Duis+congue+lorem+eget+sapien+lobortis+in+vulputate+enim+sodales.+Nunc+blandit+sapien+at+orci+commodo+gravida.+Praesent+nec+ultrices+justo.+Suspendisse+vitae+placerat+ligula.+Nam+convallis+aliquam+diam+ac+placerat.+Suspendisse+potenti.+Cras+in+pretium+odio.+Mauris+consequat%2C+massa+id+congue+condimentum%2C+magna+enim+egestas+ligula%2C+eu+laoreet+odio+nisl+non+sapien.%0D%0A%0D%0ANam+lectus+tellus%2C+molestie+ut+iaculis+nec%2C+facilisis+volutpat+massa.+Nullam+vestibulum+orci+vel+magna+eleifend+varius.+In+at+vulputate+justo.+Phasellus+nec+enim+ut+lorem+blandit+lobortis+et+nec+justo.+Nunc+et+quam+vel+erat+congue+adipiscing.+Nullam+placerat+adipiscing+lectus+vitae+tempus.+Ut+in+pulvinar+dolor.+Ut+pulvinar%2C+sapien+vehicula+congue+adipiscing%2C+turpis+ligula+dapibus+augue%2C+nec+molestie+lorem+dui+ac+ipsum.+In+id+nunc+at+nisi+consectetur+congue

Don't you use POST for this? A GET request used to be very limited. It depends on your IIS version.

commented: making the gears go 'round! +4

We recently moved over to a IIS server (from Linux....don't ask me why), and it was a server problem. I re-installed FastCGI and set my php.ini back to default and went through the settings again.

Stupid IIS. Thank you pritaeas for making the gears in my head move =)