0

hi, i have installed XAMPP, but i would like to run my localhost from another computer..

Edited by ushajase: n/a

7
Contributors
8
Replies
35
Views
5 Years
Discussion Span
Last Post by Dipesh_2
0

Type in the ip address of your computer. If you are using a router, you may have to enable port forwarding.

0

For example if you have two computers (that are on the same local area network!), the computer with the name "ComputerA" is running XAMPP, and you want to access this XAMPP server from the computer with the name "ComputerB", then here's what you do:

On ComputerB, start up your web browser. In the address bar, type: ComputerA/projectname. For example if you have a project called "testproject" in your XAMPP's htdocs folder, you can access it by going to "ComputerA/testproject". Hope this helps :).

Edited by minitauros: n/a

0

Thanks to all...ya i tried this,but
following error will be appeared..i don't know the exact problem..


Access forbidden!
________________________________________
New XAMPP security concept:
Access to the requested directory is only available from the local network.
This setting can be configured in the file "httpd-xampp.conf".
________________________________________
If you think this is a server error, please contact the webmaster.
Error 403
priya
10-Feb-12 10:05:12 AM
Apache/2.2.12 (Win32) DAV/2 mod_ssl/2.2.12 OpenSSL/0.9.8k mod_autoindex_color PHP/5.3.0 mod_perl/2.0.4 Perl/v5.10.0

0

go to xapmm-control in the task bar

xampp-control->Apache-->Config-->httpd.conf

a notepad will open with the config file

Search for Listen 80

one line above it,there will be something like this:12.34.56:80

change it

12.34.56:80 --> <ur ip address eg:192.168.1.5>:80

restart the apache and check it
hopefully it will work...

0
Open httpd.conf
find

ServerName localhost:80
#ServerName xxx.xxx.x.x:80
#
# Deny access to the entirety of your server's filesystem. You must
# explicitly permit access to web content directories in other 
# <Directory> blocks below.
#
<Directory />
    AllowOverride none
    Require all denied
</Directory>

Now change to

<Directory />
    AllowOverride All
    Require all granted
</Directory>

save it and restart apache
This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.