Hello,

We are sending email using these settings:

$config['smtp_host'] = 'ssl://smtp.gmail.com';
$config['smtp_port'] = 465;
$config['protocol'] = 'smtp';
$config['mailtype'] = 'html';
$config['smtp_user'] = 'email@gmail.com';
$config['smtp_pass'] = 'password';
$config['smtp_timeout'] = 40;

Thats ok it works. For few days. Later it stops sending. THen we go to gmail acount in web interface to login. It is not able to login, it asks to enter capcha letters.

Then after logging in to web interface, PHP also started sendign emails.

How could this be related? Anyone had same problem?

Recommended Answers

Generate an application password and use that to sign in through SMTP: http://support.google.com/a/bin/answer.py?hl=en&answer=1032419

Jump to Post

How many e-mails are being sent? It sounds like gmail has rumbled the fact that this is not just personal mail, but commercial. If you are sending mass e-mails you are gonna have to pay......

Jump to Post

For such simple task so long solution. I dont get it.

Read this and see if it may helps (not sure of it but it might):

https://support.google.com/mail/answer/78775?hl=en

Jump to Post

All 9 Replies

thanks, will try later.

I tried it, but after some time agian webmail was asking to enter from captcha and sending emails stopped working even with generated application password.

For such simple task so long solution. I dont get it.

Maybe you can recommend some other email sending service free and withot those nonsenses?

How many e-mails are being sent? It sounds like gmail has rumbled the fact that this is not just personal mail, but commercial. If you are sending mass e-mails you are gonna have to pay......

no, we are just currently tring to send like 3-4 emails per day. In near future maybe it will grow to only 10 emails per day :) and if it wants money, then why it should not throw some message that it needs money?

Making email server on ubuntu there is no quick and easy way as my co-worker said. But its 2013 - there should be enough mail services I think.

Thanks, I read it and I see the answer:

Are you able to log in to the Gmail web interface?
Visit http://mail.google.com to log in to Gmail. If you see a CAPTCHA (a security image with distorted letters), you'll need to log in before you can enable IMAP access. If you're locked out of Gmail, please wait one hour and log in to Gmail again.

But we know it - when we enter the capthca, then ok. After some time it requests cat[pcha againg and php aplication cannot send it again. We don't want to cehck everyday gmail interface if there is captcha requested.

Member Avatar

But we know it - when we enter the capthca, then ok. After some time it requests cat[pcha againg and php aplication cannot send it again. We don't want to cehck everyday gmail interface if there is captcha requested.

Try to change your port from

$config['smtp_port'] = 465;

to

$config['smtp_port'] = 25;

This is from the link:

If you tried configuring your SMTP server on port 465 (with SSL) and port 587 (with TLS), but are still having trouble sending mail, try configuring your SMTP to use port 25 (with SSL). 

thank you, I will try

Be a part of the DaniWeb community

We're a friendly, industry-focused community of 1.20 million developers, IT pros, digital marketers, and technology enthusiasts learning and sharing knowledge.