0

Hi All,

Similar problem to my previous post. I've made some progress and managed to get it working on my localhost but on the host server it still flops. I have been told to save the wsdl to file and access it from the file. However, I am not familiar with the process and would like to have some things clairified.

When I try to access the wsdl url it throws a soap error:

Fatal error: SOAP Fault: (faultcode: WSDL, faultstring: SOAP-ERROR: Parsing WSDL: Couldn't load from 'https://secure.authenticator.uat.uk.experian.com/WASPAuthenticator/TokenService.asmx?wsdl' : failed to load external entity "https://secure.authenticator.uat.uk.experian.com/WASPAuthenticator/TokenService.asmx?wsdl" )

When I access it from the file I get:

NULL

From this I assume that I am accessing the wsdl fine from the file but I am missing something integral that allows me to return the necessary data. I have been reading up (Googling - Lord knows where I would be in the world without Google), and I have seen that I may also need to save the namespace to file ('http://www.uk.experian.com/WASP/STS'). However, I was wondering if this could be accessed via the soap call; or if I can't access the wsdl via the soap call then maybe it is the same for the namespace.

My code thus far:

$options = array(
    'local_cert' => dirname(__FILE__).'/cert.pem',
    'soap_version' => SOAP_1_1,
    'exceptions' => true,
    'trace' => 1,
    'cache_wsdl' => WSDL_CACHE_NONE,
);

$authenticationBlock = ...xmlstuff...


$location = "https://secure.authenticator.uat.uk.experian.com/WASPAuthenticator/TokenService.asmx";
//$WSDL = "https://secure.authenticator.uat.uk.experian.com/WASPAuthenticator/TokenService.asmx?wsdl";
$WSDL = "TokenService.asmx.xml";


try {
    $objClient = new SoapClient($WSDL, $options);
    $objResponse = $objClient->__doRequest($authenticationBlock, $location, 'http://www.uk.experian.com/WASP/STS', SOAP_1_1);
} catch (soapFault $fault) {

    trigger_error("SOAP Fault: (faultcode: {$fault->faultcode}, faultstring: {$fault->faultstring})", E_USER_ERROR);
}

var_dump($objResponse);

Any help on this matter would be greatly appreciated.

1
Contributor
2
Replies
12
Views
3 Years
Discussion Span
Last Post by Tinnin
0

tried $location = "TokenService.asmx.xml";

same result: NULL

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.