Hi All,

I am working with a Magento (v1.8.1) site, which until a week or so ago, was working perfectly. I am using the SM_AMAZ theme, and have no plugins which could interfeare with performance.

Everything will be fine, then something in the admin panel will get changed, and the entire site will go down. By 'go down', I mean Magento serves no HTML output whatsoever. Just a blank file. I have pestered the hosting firm to provide me with a stable backup, and within an hour the site was facing the same problem. So I compared cool with broken and found all of the file changes were in the 'cache' folder.

Being clever, I wrote a PHP class that would copy+replace the cache files from the working directory to the broken one - which worked like a dream. Upon closer inspection, Magento seems to be caching the wrong files or overwriting the working chache every time it gets refreshed (every time I change a setting). I can keep solving this by running my little patch every time I change something and that works, but solves nothing.

So then I tried to disable caching layout files (as these seem to be causing the problem), but when I try to disable it, it refreshes AS it disables it. So I use my patch, which makes the cache 'Invalid', so it must re-cache again.

Is there a way to plant the old files in and disable the cache from refreshing in the future? Or does Magento have a core class that handles caching, where I could plant my patch?

Thanks for your help, I've been splitting my head for hours over this and just about fed up with it...

3 Years
Discussion Span
Last Post by imti321

The easiest way to disable cache is by using SQL query:

UPDATE core_cache_option SET value=0;
And clear your cache folder just to be sure:

rm -rf <YOUR SITE PATH HERE>/magento/var/cache/*
In Magento Enterprise Edition you also have to clear the full_page_cache directory :

rm -rf [YOUR SITE PATH HERE]/magento/var/full_page_cache/*


I've cleared the cache folder and set those values to 0 in the db - still the same

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.