hello guys, good morning
one of our servers recently upgraded to Ubuntu 14.04 so for this PHP upgraded to 5.5.9
all scripts on this server stopped working because they use a functions not supported by newer version of PHP,
I need to downgrade PHP to 5.3 so I can make all scripts work again.
I dont care for security resons for updating PHP, so its ok to back to older version of PHP.
I used this tutorial but still my php 5.5

sudo apt-get purge php5
wget -O php5_3.tar.gz http://us1.php.net/get/php-5.3.28.tar.gz/from/this/mirror
tar -xzcf php5_3.tar.gz
cd php5_3
./configure
sudo make
sudo make install

php.jpg

But in ssh when using php -v
its shows like this

php2.jpg

Member Avatar

How about updating the few scripts that don't work? There can't be that many surely? Which functions are affected?

as for error.log its show me a whole file with all functions like mysql_connect , mysqli_connect
I really dont know which function is not working.

Member Avatar

Neither of those should cause a problem - even mysql_connect, but the migration (5.4->5.5) file states:

The original MySQL extension is now deprecated, and will generate E_DEPRECATED errors when connecting to a database. Instead, use the MySQLi or PDO_MySQL extensions.

Is your error log collecting ALL errors or just fatal ones? If all, then I imagine that the vast majority of them you can ignore (NOTICES and WARNINGS).