0

Linux Mint

I logged into phpmyadmin and set the password option to 'no password' and now I can't log in. If I enter the password I was using I get this error
-> #1045 Cannot log in to the MySQL server and if I don't user a password at all I get this error.
-> Login without a password is forbidden by configuration (see AllowNoPassword) Any ideas on how I get this working again so I can log back in?

One more question about phpmyadmin. If the computer I do my development from is a different computer than the one that's actually running apache and php, which one needs to have phpmyadmin installed on it, the web/php server or the machine I'm developing from.

Thanks.

2
Contributors
8
Replies
28
Views
1 Year
Discussion Span
Last Post by cereal
1

which one needs to have phpmyadmin installed on it, the web/php server or the machine I'm developing from.

If the database is accessible from remote then you can install PHPMyAdmin wherever you want, just edit the config.inc.php file to set the IP of the database in the host index, check the documentation here:

For the AllowNoPassword check the same documentation:

In practice set $cfg['Servers'][$i]['nopassword'] to boolean TRUE and you should be able to enter without password.

Note: this kind of setup is fine only for local (your box) development.

0

I placed that line in my /var/etc/phpmyadmin/config.inc.php and now I'm getting a syntax error when I try to load phpmyadmin. I can click on pretty much anything and the error goes away but it still wont let me in.

0

Now I've went a step further. I uninstalled phpmyadmin and I made a point to delete the /etc/phpmyadmin directory to be sure no old settings were still around and yet I'm still having the same problem.

Error #1045 Cannot log in to the MySQL server when I try to sign in with a password &
Error Login without a password is forbidden by configuration (see AllowNoPassword) without a password

1

Excuse me, it was late at night and I suggested an index key of an old version, the line it should not be:

$cfg['Servers'][$i]['nopassword']

but:

$cfg['Servers'][$i]['AllowNoPassword']

as defined in the documentation link.

By the way, are you able to sign in through mysql command line client?

mysql -uUSERNAME -pPASSWORD

remove -p if password was not set.

0

Nope

garrett@mint-desktop ~ $ mysql -u root -p
Enter password: 
ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: YES)

This all happened after one adjustement in the myphpadmin settings!!!

0

I'm trying it.

How the heck is root getting 'Permission denied'?

mint-desktop ~ # kill $(/var/run/mysqld/mysqld.pid)
-su: /var/run/mysqld/mysqld.pid: Permission denied
kill: usage: kill [-s sigspec | -n signum | -sigspec] pid | jobspec ... or kill -l [sigspec]
This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.