2
Contributors
17
Replies
52
Views
1 Week
Discussion Span
Last Post by gentlemedia
Featured Replies
  • In MultiPHP INI Editor > editor mode it's on "On" Read More

  • http://php.net/manual/en/filesystem.configuration.php (documentation) says it's enabled since 4.x. https://stackoverflow.com/questions/43543297/allow-url-fopen-is-on-but-phpinfo-says-off notes same issue but an odd fix at the end. I can't test that. Read More

  • Okay, I see something strange. According to `phpinfo()`the php.ini file is located in a directory `etc` which is in the `root` (home directory). `Configuration File (php.ini) Path /opt/cpanel/ea-php70/root/etc` `Loaded Configuration File /opt/cpanel/ea-php70/root/etc/php.ini` But the php.ini file that I edit is directly in the root (home directory) and the second I … Read More

  • Read the source Luke (!) From http://php.net/distributions/php-7.0.21.tar.gz Fopen wrappers ; ;;;;;;;;;;;;;;;;;; ; Whether to allow the treatment of URLs (like http:// or ftp://) as files. ; http://php.net/allow-url-fopen allow_url_fopen = On ; Whether to allow include/require to open URLs (like http:// or ftp://) as files. ; http://php.net/allow-url-include allow_url_include = Off This … Read More

  • @ rproffitt - I've sent you a PM with some secret information :) Read More

1

In MultiPHP INI Editor > editor mode it's on "On"

Votes + Comments
Still need to check the php.ini directly to see what's what.
0

The hosting can matter here.

It's a VPS, so as of now I'm the only one in control of this server :)

0

As you read they compile php with it on/off and don't seem to use a php version that allows changing it in php.ini. Yours?

0

I'm allowed to change it. It's my server :) No, I see what you mean. A2 hosting allows their users to change PHP settings via php.ini on VPS and dedicated servers after 2014. Before that it could only be done via .htaccess.

Anyway... I guess I have to check with my provider why I can't see the changes with the phpinfo() function.

0

It's PHP 7.0.21 on Apache

I also checked if there was a .htaccess file that might have PHP directives in it which would override those in the php.ini file, but this is also not the case.

Edited by gentlemedia

1

Okay, I see something strange. According to phpinfo()the php.ini file is located in a directory etc which is in the root (home directory).

Configuration File (php.ini) Path /opt/cpanel/ea-php70/root/etc
Loaded Configuration File /opt/cpanel/ea-php70/root/etc/php.ini

But the php.ini file that I edit is directly in the root (home directory) and the second I edit is in the web root (public_html). It might be better to stick only to the one in the root and delet the one in the web root, but that's for another thread :)

Anyway... if I look in the etc directory, there's no php.ini file at all. Weird!

EDIT: I made a copy from the php.ini file and putted tit in the etc directory, to see what happend and no nothing allow_url_fopen still on "Off"

Edited by gentlemedia

Votes + Comments
Keep digging.
1

Read the source Luke (!)

From http://php.net/distributions/php-7.0.21.tar.gz

Fopen wrappers ;
;;;;;;;;;;;;;;;;;;

; Whether to allow the treatment of URLs (like http:// or ftp://) as files.
; http://php.net/allow-url-fopen
allow_url_fopen = On

; Whether to allow include/require to open URLs (like http:// or ftp://) as files.
; http://php.net/allow-url-include
allow_url_include = Off

This means with the bona-fide PHP from the source you would have to do nothing to turn it on as it is already on.

Check your source for your PHP? Read the php.ini-production file.

Votes + Comments
Yes, the production ini file is the one rhat I edit within WHM
0

When the VPS was delivered to me with CentOS 7 and WHM/cPanel installed on it. The PHP veson was 5.6. I've upgraded it to version 7.0 via cPanel but allow_url_fopen was disabled by default.

The CMS that I wil install on the server requires also to enable it so that's why I did it with php.ini

1

@ rproffitt - I've sent you a PM with some secret information :)

Votes + Comments
Read it. Shared my suspicion there.
1

Aaaaahhhh.....

There's also a MultiPHP INI Editor in WHM (Web Hosting Manager) and there I enabled allow_url_fopen for PHP 7.0 and voila.

Edited by gentlemedia

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.