0

Last couple of days I have noticed a strange behavior that I don't think is caused on my end. (Win XPpro IE6 up-to-date)

Yesterday, when I posted a reply and immediately afterward tried to edit it, the changes were saved but not displayed. When I tried to edit it again, the edit box contained the already edited text (from previous editing), but again, no changes in the post. Refreshing the page did not help. Had to go back and forth (and I don't mean the "back" button) to see the change take place.

Today I HAD to put in something in the "editing reason" box for the change to take place.

Wasn't so before.

For the record, my IE settings were not changed since the beginning.
Unless you count an installaton of Windows live messanger 8.0ß.

One more thing.
Sometimes (random to my knowledge) my "Delete" button does not work in the edit box. Works everywhere else. Irritating.

// My edit to see if it works - Dani

// second edit - Works fine for me?


My edit. (Not working if the "reason" is empty!)

Toldyou!

2
Contributors
9
Replies
10
Views
11 Years
Discussion Span
Last Post by Chaky
0

I spent a lot of time yesterday playing with creating a caching system that stores preformatted versions (ie parsed bbcode into html) of recently viewed posts in RAM on the Apache machine, to not only eliminate a query to the database server, but also eliminate having to parse all posts on the fly (in real time). The problem you're experiencing did indeed happen for about an hour or so yesterday while I was working on it. It should be fixed by now though. Can anyone else confirm?

0

Oh my goodness! It just happened to me! ... Looking into it ... it's strange because I'm saving the cached versions with names that are a combination of the post ID # and the last edit time, to (supposedly) accomidate post edits.

0

Post (no edit)

Edit 1 (no "reason")

Edit 2 (with "reason")

Edit 3 (Deleted "reason")


Solved

0

Like I said ... I am using a combination of the postid and the time the post was last edited to uniquely store each version of a post in my new handy dandy cache.

However, I had a vBulletin option enabled to not record edits made within the first 5 minutes after a post is initially created. Therefore, when you were editing your posts, the database wasn't recording that there was an edit. Therefore, a new version of the post wasn't cached, since it didn't know there was an edit made.

I've changed this to now record ALL post edits regardless of if they're made 1 second after the initial post is created or 1 day after.

0

See how it now shows your post was initially created at 6:07 and you edited it at 6:08. Before now, the database wouldn't have bothered recording that edit or displaying that notification on your post.

I think this is a small price to pay for my cache. Besides, as a forum reader, sometimes I do happen upon a post within the first minute or two after it was initially written, and I would like to know if there was a typo that someone fixed or such.

0

Sometimes it is good to have grumpy people around that have nothing else to do except complaining.:cheesy:

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.