I have been writing all of my code in Notepad since 1993. It doesn't put strange stuff in files.

I have been writing all of my code in Notepad since 1993. It doesn't put strange stuff in files.

Neither do good editors. In fact they give you a great measure of control of exactly how the file is stored.

The editing time issue is one you choose to have for your own choice of tools.

I am not using Notepad to edit these posts. I use it to edit my web pages.

I noticed the following:

- If I upload the file to put in the code tags directly from my computer, the editing trouble here does not happen.

- If I copy the code file from my website to put in the code tags, the trouble happens.

- If I copy the code file from my website to put in the code tags, the trouble happens.

Are these files hosed? Do they have embedded tabs? "Smart" quotes, etc.?

DaniWeb uses UTF-8 and it's usually rather forgiving with foreign characters.

My personal theory is that it's one of those elusive IDTenTee errors.

Are these files hosed? Do they have embedded tabs? "Smart" quotes, etc.?

Huh? Hosed? That means deleted.

I don't find unusual characters in them when I download and use Notepad.

No smart quotes (which I wish had never been thought of).

Huh? Hosed? That means deleted.

No, hosed means screwed up, not deleted.

Then who hosed hosed? It used to mean deleted in the 1990s. :icon_cheesygrin:

I have a partial solution to the editing problem. I put the same font in both Notepad and in Firefox monospace, and the jumping indents went away.

I had changed the font in Notepad, and that seems to have caused caused the trouble. But I really don't understand this, because the font is supposed to be for display, not formatting the file.

But I still have the problem that whenever I use a link or a bookmark to go get something to paste in a post, when I return, I find the edit window reset to the condition it was in when I opened the edit. If I am editing an existing post, it resets to the way the post already is on the board. If I am creating a new post, it resets to blank.