Then "contribute a new article" to the web development forum ;) You might get some useful help / ideas!

Touche :) Have to leave soon to go to a father's day bbq but I'll def post when I get home.

Is it just me or did you fix this bug? To me, it appears that all the fonts are now fixed width (which I think is perfect), and the drifting cursor problem is gone! Hurray!

The editor that we use was designed to only work with monospace fonts. I was being stubborn, and insistant that I get the editor to work with a mix of non-fixed and fixed-width fonts. Unfortunately, the editor wouldn't have it and it was causing the floating cursor bug, the drifting cursor bug, and the incorrect tab width problems. I've finally waved the proverbial white flag. But I'm NOT giving up! I'm NOT, I tell you!

I've finally waved the proverbial white flag. But I'm NOT giving up! I'm NOT, I tell you!

Nothing wrong with that. You live on to fight another day. It is also unlikely that you will get complaints from all the programming-savvy people here about having fixed-width fonts. Fixed-width fonts FTW!

N.B.: This also makes the highly criticized live preview a bit more useful!

Thread (or article) solved!

We're having huge issues with the cursor offset bug right now so I just want to give everyone a status update to stay tuned. Sorry for the inconvenience!

This bug SHOULD be fixed now. Please let me know if it happens to you again.

It's not fixed. I see problems with the cursor in Chrome.

Try clearing your browser cache.

In my response in this thread when I pasted the code, and started indenting with 4 spaces manually, the offset bug appeared (using IE9). As soon as I manually create and paste an URL it happens too (in IE9). Long live IE... Opera appears working fine.

I had the cursor offset problem an hour or so ago. I started typing this post and noticed that the cursor started having the same problem in this post. I tried re-entering all of the text to see if I could determine where the problem was occurring but I couldn't make it - OK. It happened as soon as the edit window expanded by one line to accomodate the extra text. It gets worse for every new line that gets expanded. I'm using Firefox 13.0.1.

I'm trying to upload a screen cap but when I click on "Files" I got the "Upload Attachments" area but no actual area to specify a file. I'll try to save, then add an attachement with an Edit. edit

It doesn't show up in the screen cap, but the cursor is actually between "b" and "ut" on the last line.

Have you cleared your browser cache and are still experiencing the problem?

I cleared the cache (even used ccleaner) and got exactly the same problem in the same area.

Also, I had to post this twice to get it to show up.

The next time it happens, please let me know the EXACT text and formatting that triggered it. Without a reproducible test case, there's unfortunately nothing I can do.

I tried to reproduce the problem in Internet Explorer 10 and couldn't. It happens only in FireFox. But it happens in FireFox consistently. If I type until I fill up the initial edit window everything is fine. As soon as I type the final character in the initial window things go funny. If you think it would help narrow down the problem you are welcome to remote in with TeamViewer and see for yourself. edit1

It works fine for me in Firefox. I am not able to duplicate this behavior.

Please tell me the EXACT text that triggers it for you. Thanks!

Oh, I see ... I just got it to work for me with the text in your post above. I tried ten different times with random gibberish text and I couldn't replicate the behavior. Thanks!

Just happened to me again.  I was half way typing a response to a question when the cursor moved to the wrong location in the edit box.  The only way I could regain control was to save what I had typed then edit the post.

Are you using Firefox?

Let me know if it happens again please.