I moved this post to a new question. since it was getting lost.
Something I've been meaning to bring up for sometime. I can't login on Chrome Mobile. I get the sign in page, but then it just goes back to the generic home page with the login link.
I'm using Android. It could be a cookie issue, I guess, though I haven't messed with any settings and there haven't been any warnings about not being able to set a cookie. It doesn't present any error message, the login is just basically ignored, and I'm re-directed to the home page. When I look at the top menu it only shows links to join or login .

It sounds to me like a cookie issue, but I only have access to an iPhone and I can't reproduce this on Chrome for iOS. Can someone who has an Android please test it out?

I just looked on the Site Settings for Daniweb and the Dazah login page. Both have the Cookies setting set to Allowed.

I tried replying to a post, just in case the login was valid but the web page wasn't showing it, and it refused to submit, it just returns back to the same page with the editor still active and the reply still in it.

Did it ever work for you, by any chance?

Nope. I only tried it in about the last couple of months.

Has this now been fixed by any chance?

Just tried it it appears to work now. thanks. I'll mark this solved

Something tells me you were suffering from the same race condition bug as cereal, as documented in the other thread from yesterday.