My screenshot software seems to be having problems, so I'll have to just describe it.

So I gave James +rep here in this thread.

It shows up in the main Activity Stream that I did it (time 9:50 Pacific - five minutes ago). But it doesn't show up on the post (shows as 0, not 1, and I don't see my comment in yellow), nor do I see it in James' profile. I can change it from 0 to 1 (sometimes), but always with a delay and it seems like it's making a quick bounce to 1, then immediately back to 0. No option to add a comment, though I successfully added a comment the FIRST time (but it disappeared).

Hmm. NOW it worked. If you look at the Activity Stream, I gave him rep at 9:50 and and 10:00 am, but clearly only the one at 10:00 am showed up.

So, problem solved, I suppose, but I'll leave it as unsolved in case you want to check it out.

Unfortunately I'm not able to debug this after-the-fact as the second vote overwrote the first vote in the database, and therefore there's just one record with the latest timestamp. Does this happen regularly? I've never had a problem voting but, alas, I tend to just be someone who votes without commenting.

First and only time it's happened for me. Not sure if you can go back and check the Activity Stream and note that it showed up as me giving rep twice, ten minutes apart today, or even if that would have helped. So something clearly went through halfway. That Activity Stream would have been the screenshot I would have sent you. Not sure what ends up in your database, but the first time through it showed up in the Activity Stream, but not in the thread or on James' profile. Second time ten minutes later worked as it should.

As you can see, it ended up working in the end, so if nothing looks wrong in the code and you get no more reports on it, I imagine I'd chalk it up as "One of those things" and put it in the back, way in the back, of my mind.

Yeah, I'm going to wait until I find out if it's reproducible. I've been making a lot of code changes lately so it's possible you voted at the very moment a file was being uploaded and something weird happened.