This site was made by a previous designer and the client needed some updates. The header and nav were an image file before and I recreated them as include files with CSS. I have tried different variations to input the includes and it still not showing up live.
Here is the code:

<?php require_once('includes/header.html'); ?>

<!-- main navigation -->
<?php require_once('includes/navigation.html'); ?>
<!-- end main navigation -->

Thanks!

Recommended Answers

use 'include' not 'require_once'

Jump to Post

All 4 Replies

Screen_Shot_2013-01-13_at_5.15_.13_PM_

This post has no text-based content.

use 'include' not 'require_once'

use 'include' not 'require_once'

Not sure this will help, since "include" and "require" are almost the same thing, except "require" will kill the script if the file is not found.

aglaf1979, Do you have error messages turned on? Are you getting any errors when you try to include the files? Can you show your directory structure for your files?

Not sure this will help, since "include" and "require" are almost the same thing, except "require" will kill the script if the file is not found.

Quite right EvolutionFallen, it was early in the am when I posted!

@aglaf1979, it may help if you post your code using the 'code' formatter, rather than using a screenshot, as well as the above.

Be a part of the DaniWeb community

We're a friendly, industry-focused community of 1.20 million developers, IT pros, digital marketers, and technology enthusiasts learning and sharing knowledge.