0

Hello,

My Google Chrome browser has been redirected to"Search.Babylon.com". Ever since I downloaded Internet Download Manager from Download.com, this redirection began. Using CCleaner, I uninstalled Internet Download Manager and two Babylon entries, however Chrome is still redirected to Babylon. In the Chrome settings, Google is my default browser, but this Babylon still redirects. Any help would be much appreciated. Thank you.

3
Contributors
6
Replies
11
Views
5 Years
Discussion Span
Last Post by Inlovewithnight
0

Search.Babylon.In Chrome, Go to the Wrench icon -> Tools -> Extensions. Uncheck “enabled” next to Babylon and then press the “Remove” button.

You must restart your browser for the changes to take effect.

Edited by caperjack

0

It's got cunning. They know you're going to try that...
Download OTL from http://oldtimer.geekstogo.com/OTL.exe
Dclick OTL.exe to start the application; in the window that opens choose, Scan All Users, Minimal Output, Standard Registry ALL, check both LOP and Purity boxes, and then press Run Scan.
The scan will take maybe 5 minutes; 2 notepads will present [they are saved to the place from where you ran OTL.exe] - post both, please.

0

Hi, I think I have fixed this. I ran Spybot which picked up quite a few entries for Babylon. I then went into Settings on Chrome. I looked for "on startup". I then hit "Open a specific page or set of pages." Then onto "set pages". Another window opened up that said startup page. In there Babylon was listed. So I deleted Babylon and typed in Google.com. Everything seems to be back to normal. No redirecting. If you think I should run OTL I will do it. Please let me know when you have a chance. Thanks so much.

0

Good work. No need for OTL now; Babylon is a persistent, well-embedded toolbar and redirector, no more.

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.