AAH. I'm gonna try as hard as possible not to use all caps and cursing in this post. This is just ticking me off.
Alright, so I upgraded to the newest AmaroK. 1.4.8. Turns out, it uses libgpod0.5.4 or something, and I need 0.6.0 to sync to my iPod.
Alright, so I uninstall the old one and leave 0.6.0 (which I already had installed from my old install, it just wasn't compiled against AmaroK).
I install AmaroK 1.4.8 from SVN sources, and it still doesn't work. Corrupted iPod database, oh joy.
So I uninstall both, and compile libgpod0.6.0 from sources, and I STILL can't install AmaroK. It basically installed libgpod0.6.0, but didn't tell my system that. So gtkpod and AmaroK won't work, and AmaroK won't even compile. Great.
So I uninstall the compiled version of libgpod0.6.0 and figure I can just install it from Synaptics again and try from there. So I try to install from there and it says libgpod0.6.0 is referred to by another package. IT DOESN'T EXIST. WHAT AM I SUPPOSED TO DO NOW!?
So I download a libgpod0.6.0 .deb file, try to install it, and bang:
libgpod3 depends on libglib2.0-0 (>= 2.15.6); however: Version of libglib2.0-0 on system is 2.14.1-1ubuntu1.
GREAT. MORE TROUBLES.
So, now I'm stuck with: A corrupted database on my iPod touch (no music available, but its on the iPod). No AmaroK: I can't play any music there either.
Can ANYONE help me? John A, I know you'll post here. PLEASE.