0

Hi

I have windows XP with service pack 3 machine.
I installed Apache 2.2 and tested working fine.
And then I installed php 5.3.1.
When I start Apache, it doesn't start and getting get following error in popup window.
"Apache HTTP Server has encountered a problem and needs to close. We are sorry for the inconvenience."
But I don't get any error in the log fine.

After studing in detail, I found this enrty in httpd.conf
LoadModule php5_module "C:/php/php5apache2_2.dll"

But this file is already there in the folder.

In windows event log; I found this entry

Faulting application httpd.exe, version 2.2.14.0, faulting module php5ts.dll,
version 5.3.1.0, fault address 0x000e619a.

When comment it out LoadModule, It work fine. So itis the PHP problem.

I tried with both version of PHP 5.3.1, VC6 x86 Non Thread Safe and VC6 x86 Thread Safe.
But still the same problem. I am getting off with PHP technolgy. I wasn't expecting
this complex to just to get Apache and PHP working. No wounder, why people move to microsoft product.

Please please can someone help me with this problem.

many thank

2
Contributors
1
Reply
2
Views
7 Years
Discussion Span
Last Post by nileshgr
0

Don't curse Apache and PHP. Apache is used by more than 60% servers in the world !

Its windows' problem.

Better use CGI / FastCGI interface. This mod_php thing is always troublesome at least by my experience.

My server uses Apache on Linux but I never use mod_php. I always rely on FastCGI. It gives better performance and easier to setup.

Edited by nileshgr: n/a

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.