0

I did a fresh install of Fedora 10 on my laptop. I'm trying to get my wireless nic connected and not having much luck. The setup looks correct, has an ip, but can't access anything. I'm not sure what I am missing.

1. lspci command returns: 02:01.0 Network Controller(0280): Intel Corporation PRO/Wireless 2200BG Network Connection(8086:4220) (rev05)

2. When I go to system>admin>network the wireless nic shows up on eth0

3. Wireless settings tab shows
mode: master
SSID is set to my wireless SSID(tried auto as well with no luck)
channel and transmit rate set to auto
key field is blank, I turned off all security on my router to simplify troubleshooting

4. Wireless device on eth0 is active

5. When I run an ifconfig the wireless nic is shown with a correct ip address. I can ping loopback address, router, my desktop and websites(by name and ip)

When I activate the wireless eth0 I first get a brief error that says SET failed on device eth0; invalid argument, but then it continues to obtain ip info and activates successfully.

Any ideas?

2
Contributors
2
Replies
3
Views
8 Years
Discussion Span
Last Post by Squires
0

>I can ping loopback address, router, my desktop and websites(by
>name and ip)
So you can ping everything on the internet, but your browser just can't use your connection?

0

Correct John, and I have since figured it out...firefox was defaulting to work offline, even if I had a connection. I cleared the check by work offline and was working fine. I feel pretty stupid right now for not catching that sooner.

I looked into why it was starting in offline mode. I found that network manager seems to be the cause. I disabled network manager and now firefox starts in online mode.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.