Uh, just woke up and for breakfast I got to run into a Linux problem .. I turned on my pc (Kali Linux) and it has no sound? Ik weird .. used to work until I went to bed ... I have xfce DE. The error I get when I click on the mixer is GStreamer was unable to detect any sound devices. Some sound system specific GStreamer packages may be missing. It may also be a permissions problem.

If I run alsamixer in terminal I get the following:

ALSA lib pulse.c:243:(pulse_connect) PulseAudio: Unable to connect: Access denied

cannot open mixer: Connection refused

I checked drivers, I have gstreamer1.10-good/bad/ugly/base already installed (It was working until this morning). After about 2 hours of google world I am about to give up as nothing really comes close to solve this .. any suggestions?

Turn off -> Turn on fixed it, weird stuff

Sometimes, drivers miss a hardware event/interrupt and get into some space where they cannot continue to operate normally. At that point, it is time for the 3-finger salute, as you found out. As far as I'm concerned, drivers should be able to recover from this, but that is not a trivial exercise to accomplish in many cases.

Be a part of the DaniWeb community

We're a friendly, industry-focused community of 1.20 million developers, IT pros, digital marketers, and technology enthusiasts learning and sharing knowledge.