0

I have a dedicated box running Fedora Core 4/Plesk. I can receive emails just fine using the pop server: mail.domain.com (as directed by Plesk). However, when I try send mail using mail.domain.com (as directed by Plesk) I cannot connect to the server.

I submitted a trouble ticket to my dedicated provider but got a useless response, "You will need to configure your mail server software on your server."

Any ideas what I need to configure? There is no setting in the control panel to enable/disable SMTP. Could it be a DNS issue?

2
Contributors
2
Replies
4
Views
11 Years
Discussion Span
Last Post by stymiee
0

One thing you should check is that you are actually allowed to send mail via port 25 (SMTP) Outside of your ISP's mail servers. You can test this using telnet:
telnet mail.domain.com 25

If you receive a response like this:
220 mail.domain.com ESMTP

Then your connection is good, and it may be an authentication issue. If you don't then chances are your ISP does not allow you to send mail outside of their network. This is a common practice by residential ISP's to prevent people from spamming others on a residential line. If this is the case, you will need to open up an alternate port on your mail server. This is relatively easy.

In /etc/xinetd.d/ There is a file called smtp_psa, you will need to copy this file to another filename (in the example I'll use smtp2_psa).

In this new file, you will want to change the line:
'service smtp' to 'service smtp2'

Once this is complete, you will need to modify your /etc/services file, and add the smtp2 service:
smtp2 26/tcp mail
smtp2 26/udp mail

Then restart xinetd.

You will then need to modify the port in your mail client to use the new SMTP port.

If this isn't the case, please provide more error messages to help us further diagnose the issue.

0

I did get correct response: 220 mail.domain.com ESMTP

This is the error I get when trying to send mail through my mail client:

This message could not be sent because connecting to SMTP server mail.domain.com failed. The server may be unavailable or refusing SMTP connections. Please verify that your SMTP server setting is correct and try again, or else contact your network administrator.

This occurs no matter where I try to send mail from (four separate locations with different ISPs).

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.