-1

I'm currently working on my project. I use Vertrigo as my virtual server. However recently i always see this message when i use it....
MySQL database server does not work correctly. Check whether other applications use the important port (3306)...
i'd no clue at all but then i reconfigure my MySQL..problem still persist.
Any solution here? How do i check whether any application using that port as well? Thanks

Votes + Comments
have cum wid diz many tyms......it continue 2 b often..., so , kindly go 4 an alteration
12
Contributors
13
Replies
18
Views
9 Years
Discussion Span
Last Post by ma.podoplelov
0

hmm.. AFAIK, only mysql uses port 3306. To check what ports are being used, open command prompt and type netstat -ab. It ll list all the applications and the ports used by those applications.

Maybe that port is blocked by your firewall ?

0

Did you ever install any web sever like Apache .
1) First you might know that MySQL and MS SQL do not like each other .

Correct me if I am wrong .

0

I have the same prob too :-( Any suggestions?

That problem description is very inacurate, you better provide full description of your problem...

0

I installed vertrigo server. The installation went smoothly, the only thing I changed was the installation path, instead of c:\program files... I gave C:\software.

When I attempt to start vertrigoserv, I can start Apache, PHP work correctly, but not MySQL.

0

After MUCH Googling, I couldn't find the solution to this very same problem until I had an epiphany. MySQL would always run fine on installation, but it would error when it was started again any time after that. This led me to the solution:

If you are using Windows Vista, right click your Vertrigo shortcut and select "Run as Administrator."

I pulled my hair out looking for this solution and it's so obvious. I hope this helps anyone else with the same trouble.

0

As the Error Says 3306 is being used by some other application

user netstat to find out which application is using it or try turnning off firewall if any

or else you have to use different port for Mysql

0

MySql database server does not work correctly. check whether other application use the

important por(3306)and terminate them.Moreover, check firewall settings and correctness the

configuration files <--- what should i do to solve the problem

0

you will find

port=3306

in my.ini or my.cnf file
change that to some thing else say 3307 n try

or you have to check if any other application is using it
go to CMD and type netstat ,there you will find if 3306 is in use or not
if no application is using 3306 try disabling firewall

0

Hi I know this is an Old Thread but I would like to answer this for any one who looks, It may not be a program using the port but a service, Such at apache or apache-Tomcat if they are running End the service and your port should be open.

0

Hello fellows. i had the same problem, and solved it this way:
i discovered that i already have mysql installed on my machine by another program, and so it was running as a win service. so i killed it and then installed full mysql
hope it will help.

sorry for my english.

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.