0

Hello,

When trying to use mysqldump, I got this error message:

mysqldump: Got error: 2003: Can't connect to MySQL server on 'localhost' (10061) when trying to connect

According to the MySQL Documentation Library, error 2003 means that my network connection has been refused and that I should check that there is a MySQL server running, that it has network connections enabled, and that the network port specified is the one configured on the server.

Now MySQL is running as a service and is started on my machine. My Questions are:

1. How do I enable network connections?
2. How do I specify that the network port specified is the one configured on the server?

Any assistance will be really appreciated. Thanks in advance.

http://dev.mysql.com/doc/refman/5.1/en/can-not-connect-to-server.html
2
Contributors
3
Replies
5
Views
7 Years
Discussion Span
Last Post by nileshgr
0

If you really want TCP/IP networking then find for this in my.cnf -

skip-networking

and change it to

#skip-networking

If your use is just local (only your PC) it is recommended that you don't enable TCP/IP networking.

Mysqld by default communicates using Unix sockets which is meaningless on Windows. To enable Named Pipes (windows sockets)-

enable-named-pipe
0

Thanks for replying itech7.

I am using MySQL on my computer only. Now regarding the enable-named-pipe, how do I use this to get mysqldump to start back working again? In the "my.ini" file, I found this (among other things):

[mysqld]
skip-networking
enable-named-pipe
# The Pipe the MySQL Server will use
socket=mysql

Using the Windows command prompt, when I type "mysqldump" it displays the mysqldump options etc, but when I try to execute this statement:

mysqldump -u root -p databaseName > "C:\FolderName\databaseName.sql"

I get the 2003 error
I wish I knew why it stopped working, not sure what I did to cause it to stop working. I also have XAMPP installed on the same drive - with MYSQL as the only service both installed and running ... could this be conflicting with MySQL? I am not using XAMPP, but I am using the MYSQL command line.

Hope this sheds more light on my problem.

Edited by blue-iguana: n/a

0

Thanks for replying itech7.

I am using MySQL on my computer only. Now regarding the enable-named-pipe, how do I use this to get mysqldump to start back working again? In the "my.ini" file, I found this (among other things):

Using the Windows command prompt, when I type "mysqldump" it displays the mysqldump options etc, but when I try to execute this statement:

I get the 2003 error
I wish I knew why it stopped working, not sure what I did to cause it to stop working. I also have XAMPP installed on the same drive - with MYSQL as the only service both installed and running ... could this be conflicting with MySQL? I am not using XAMPP, but I am using the MYSQL command line.

Hope this sheds more light on my problem.

Since I'm not using Windows, I don't know how to set the named pipe location file. I just found that on mysql docs. Ask on mysql forum. You'll get a better response there.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.