0

Hi,

I can't manage to set a root password no matter what I try. I've tried to uninstall and reinstall. I've tried to get the new version and replace the old one with it. I've totally deleted all mysql files off my machine and reinstalled mysql but I STILL get these problems:

I've tried:

mysqladmin -u root password "newPassword"

But I get this error:

mysqladmin: connect to server at 'localhost' failed
error: 'Access denied for user 'root'@'localhost' (using password: NO)'

I've tried:

mysqld_safe --skip-grant-tables &

But I get this error:

'mysqld_safe' is not recognized as an internal or external command,
operable program or batch file.

I've tried:

mysqld --skip-grant-tables &

But then I get this and nothing happens:

101022 21:39:31 [Warning] '--default-character-set' is deprecated and will be re
moved in a future release. Please use '--character-set-server' instead.


So I really just see no winning here.

Thanks,
Ashton.

2
Contributors
2
Replies
3
Views
7 Years
Discussion Span
Last Post by AshtonHogan
0

You seem to have reset the admin password with mysqladmin -u root password "newPassword" Afterwards you try to connect but you do not provide a password, as proven by error: 'Access denied for user 'root'@'localhost' (using password: NO)' Could it be that you just forgot the password option -p as in mysql -uroot -pnewPassword

0

Yes. Well, not really - The password was set to blank or default or something when I installed MySQL 5.2. I can't use the mysql -u root -p password command because I also get the error: 'Access denied for user 'root'@'localhost' (using password: NO)'.

However, I resolved this problem simply by installing an older version. Version 5.0 of MySQL did the trick for me. I think the new versions so far just suck. I'm using Windows 7 x64 though; I'm guessing they didn't do much testing on this OS.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.