0

Hi everyone! Is there a way to set a MySQL server to not automatically start execution until prompted by the user? I recently installed a MySQL server on Windows and I'm having a little bit of problem at start up.

Everytime I go to the command prompt to type the command mysqld --console to start the MySQL server, errors are returned to me that say an application is already using the MySQL server and that I should close this application to get rid of the error. But there's no application that's actually using it. I found a way to terminate this unknown "application" by ending the process mysqld.exe in the task manager. But the problem is, everytime I turn my computer on, the mysqld.exe is again one of the processes running; it's like automatically running upon booting the PC so I have to terminate this process again in the task manager to successfully start the MySQL server. I do this everytime and I'm thinking there must be a way to terminate this process so that I won't be terminating it in the task manager and such that I could successfully start the MySQL server when I want to. So can anyone give me a way to stop the mysqld.exe from running everytime I turn on my PC?

Answers will be greatly appreciated. Thanks all!

3
Contributors
12
Replies
15
Views
6 Years
Discussion Span
Last Post by shinsengumi
0

Go to services, and set the MySql service to start manually.

Thanks for replying, but how do I go to services? Do I need to reconfigure the MySQL instance?

0

No. Not sure what OS you're running, most likely computer management, then services.

Windows XP. I'm trying to find it now but could you give me more detailed way to go to computer management?

0

Ow, XP. I think you can open it by typing msconfig.exe in the box, after clicking start - run.

I found MySQL under Services but there is no option there to configure it to start manually. A check box is located beside MySQL, its status is Running and it is currently checked. And I also have the options to Apply the changes I'm going to make (which is to uncheck it maybe?) What's the best thing to do?

0

Don't have XP here, so you'll have to wait until I'm home. Can't remember how to change the setting from the top of my head. Perhaps someone else will reply with the correct procedure before that.

0

Don't have XP here, so you'll have to wait until I'm home. Can't remember how to change the setting from the top of my head. Perhaps someone else will reply with the correct procedure before that.

OK then, if no one else can answer the problem, I hope you could answer it once you're home. Thanks again

0
NOTE: On the steps below
">"  mean "click on"
">>" mean "double click on"


>Start	>Control Panel	>>Administrative Tools	>>Services >>MySQL

Change Startup type to Manual

>Apply
0
NOTE: On the steps below
">"  mean "click on"
">>" mean "double click on"


>Start	>Control Panel	>>Administrative Tools	>>Services >>MySQL

Change Startup type to Manual

>Apply

Thanks for replying. I've followed the steps thoroughly but they didn't seem to work. Do I need to reboot my PC for the changes to be fully applied? I'm asking coz I'm currently doing something that inhibits me from rebooting the PC.

0

Note that this change only affects startup. The process that is running is not affected, unless you choose "stop".

0

Note that this change only affects startup. The process that is running is not affected, unless you choose "stop".

So I guess the change will only take effect once I reboot the PC, right? Maybe I'll do it later. Anyway, I'll ask a question in this thread if the problem isn't solved yet.

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.