0

Hi I just installed Oracle 11g R2 on my Win 7 Ultimate x86 machine in compatibility mode (XP SP3).

It showed that the setup completed successfully (without a single error & warning, I got few when I ran it in Win 7 without compatibility mode enabled.).

Now I am trying to open up sqlplus, getting two issues:
1. First I am getting dos-like console asking for username & password for sqlplus. Why I am not getting the normal window.
2. Also I am unable to login in sqlplus with the username & password I entered during installation.

I am newbie in Oracle. Please help!!!

5
Contributors
8
Replies
15
Views
6 Years
Discussion Span
Last Post by ryanjayson
0

You need to login at console only or else use the SQL Developer.

SQL * PLUS is not shipped with 11g anymore.

Check if your database service is up and running.

0

I did not made any changes to Oracle's services startup.
Following services are running by default:
1. OracleDBConsoleorcl
2. OracleMTRecoveryService
3. OracleOraDb11g_home1TNSListener
4. OracleServiceORCL

Here is what happens when I attempt to login:

SQL*Plus: Release 11.2.0.1.0 Production on Fri Feb 18 19:36:55 2011

Copyright (c) 1982, 2010, Oracle. All rights reserved.

Enter user-name: ORCL
Enter password:
ERROR:
ORA-01017: invalid username/password; logon denied


Enter user-name: orcl
Enter password:
ERROR:
ORA-01017: invalid username/password; logon denied

Enter user-name: scott
Enter password:
ERROR:
ORA-28000: the account is locked

After three attempts console window disappears.

After installation a password management window was opened to which I clicked ok.
I took snapshot of that window. So just have look at it (See attachments). It may help.

Help me atleast to login using some account (scott-tiger).

Attachments Locked_Accounts_1.PNG 39.55 KB Locked_Accounts_2.PNG 41.13 KB
0

....(above reply continued)

When I open up SQL Developer, it asks me the full path name of java.exe.
I browsed to: C:\Program Files\Java\jdk1.6.0_23\bin\java.exe & clicked Open, but it still keeps asking me the same.

Whats wrong?

Yes & one more, I have seen that you have asked other to unlock scott-tiger account.
How to do that? Help me or at least post a link that will explain me that.

Help debasisdas!!!

0

The screen shot shows the SCOTT account was not unlocked during installation.

1.login to the system account (password setting for this is compulsary,so you would have done that).
2.unlock the scott account.
3.change the password to what ever you want.

Start using.

to use sql developer, browse and set the path to javaw.exe (it will bw available under oracle home directory--bin sub directory)

0

You could also try this.

Open a command DOS window

c:\> set oracle_sid=orcl
c:\> sqlplus / as sysdba

That should get you in. You can then unlock scott and reset the system password if you don't know what it is.

alistair

0

SQL*Plus: Release 10.1.0.4.2 - Production on Sat Dec 31 13:32:14 2011

Copyright (c) 1982, 2005, Oracle. All rights reserved.

Enter user-name: sys
Enter password: ****
ERROR:
ORA-12560: TNS:protocol adapter error


Enter user-name:

can any one help me in resolving this??

Edited by Suba.s: n/a

0

Hi
At the command line set the oracle sid name

C:\> set oracle_sid=orcl (use your database name)
C:\> sqlplus / as sysdba
SQL>
Cheers
Alistair

0

SQL*Plus: Release 10.1.0.4.2 - Production on Sat Dec 31 13:32:14 2011

Copyright (c) 1982, 2005, Oracle. All rights reserved.

Enter user-name: sys
Enter password: ****
ERROR:
ORA-12560: TNS:protocol adapter error


Enter user-name:

can any one help me in resolving this??

Try this

Go to database configuration and select configure database radio button, just wait. Then close it. Log to SQL* Plus again..

I hope it solve the problem.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.