0

i have four computers connected to broadband ADSL router
MS SQL Server is installed in all computers while i have done steps given here http://support.microsoft.com/kb/914277 it had worked on local networking some time ago but now its not accessing remotely. i m confused its just because of broadband ADSL. if yes then what's the solution..if NO then why it is not working because if i want to ping the IP from client computer so it is pinging like
prompt> ping 192.168.1.20
but when i am logging from microsoft management studio as
server: 192.168.1.20\sqlexpress
authentication: sql server
username: sa
password: xxxxxx

even if i use this command
prompt> osql -S 192.168.1.20\sqlexpress -U sa
on local computer where main database is attached so it is working properly but when i am using the same command on the client computer of the network where ping is working there it is also not working....

Edited by geoamins2: n/a

4
Contributors
6
Replies
8
Views
5 Years
Discussion Span
Last Post by geoamins2
0

192.168.1.20 is not an Internet address, so it has to be the IP your router has assigned to your PC. You need to a) find out what IP your router has (if it's static or if its not you need to see if it supports dynDNS or something similar) and use that when you wish to connect remotely over the internet and b) set up a rule in your router to forward packets on port 1433 to the IP 192.168.1.20
You might want to read this: http://support.microsoft.com/kb/287932

0

192.168.1.20 is not an Internet address, so it has to be the IP your router has assigned to your PC. You need to a) find out what IP your router has (if it's static or if its not you need to see if it supports dynDNS or something similar) and use that when you wish to connect remotely over the internet and b) set up a rule in your router to forward packets on port 1433 to the IP 192.168.1.20
You might want to read this: http://support.microsoft.com/kb/287932

Yes you are 192.168.1.20 is ADSL Switch ip-address actually it was dynamically assigning IP addresses when i was trying to connect from the remote computer then i have given ip to that computer to access from remote local network client through IP... but couldn't work...

what do you suggest what should i do to resolve the problem.

0

First of all, assign a static IP to your computer with SQL. Then setup a rule in your ADSL router to forward all requests on port 1433 to that IP & port. More info on the port can be found on the link I provided in my earlier post. If you've got a firewall you'll probably need to configure that as well.

Once you've done all this you should be able to connect with the IP address your router got from your ISP.
As this involves figuring out the IP every time it changes, you might want to investigate solutions like dynamic dns. If you google dynamic dns service you'll get all the required info and the solutions. This service is also being offered free, so you might want to include that in your search as well.

PS: Some routers support dynamic DNS, you might want to check yours.

0

First Of Go SQL SERVER CONFIGURATION MANAGER In The PC Where SQL Server Is INSTALLED.

THEN AS IT'S A EXPRESS EDITION , TCP IP WILL BE DIASBLED, YOU MUST ENABLE IT.

THEN USING THE WINDOWS FIREWALL , UNBLOCK PORT 1433 FOR INCOMING CONNECTIONS.

ASSIGN A STATIC IP : 10.20.30.40 in my case

YOUR Connection string :

server=10.20.30.40,1433;database=your_db_name;user=sa;pwd=*****;multipleactiveresultsets=true
0

thank u friends 4 replies 2 solve this issue
let u update soon if it dose work

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.