0

Hello,

I'm pretty much a newbie with SQL. I have a database that is growing out of control and I'm unable to delete any records (data) from it. I've tried numerous open source applications but nothing has worked. The database is with a hosting and they provide ASP.NET Enterprise Manager. I also have Table Editor 0.81 Beta loaded on the host. I can get any program/app to connect to the database, and I can see all the tables and data, but I'm unable to delete old records. There are 2 years of old data that I need to delete. And my hosting company is screaming at me to make the database smaller. It is currently around 650MB.

Can anyone PLEASE offer some assistance to a SQL newbie, pretty please??

2
Contributors
9
Replies
10
Views
11 Years
Discussion Span
Last Post by campkev
0

need more info. what have you tried? what error messages/symptoms do you get when you try it?

0

Thanks for your response, campkev. I'm not sure I understand what you mean by "what have you tried." Applications or commands? I am trying to query a particular table that is logging impressions on banners. I have tried the following:

DELETE FROM usd_ImpressionDetails
WHERE bannerID = 13;

Where "usd_ImpressionDetails" is the table and "bannerID = 13" is just one of the many rows I need to delete. I have a half a dozen application that allow a query to the database and they all produce the same results, which is nothing.

I recently researched if perhaps the database had some kind of lock or permission limits and I was able to turn on "autoshrink" in hopes to reduce the size, but I think I need to wait until the SQL server resets or something. I also ran "dbcc shrinkdatabase bannerdb" but I'm still seeing the same size mdf and ldf files when I run "sp_helpdb bannerdb."

I'm at a complete loss here...

0

if you are executing your delete query from an application, does whatever login the application is using have delete privileges on the databases and tables you are trying to delete from? Are you getting an error when you run that query or just "0 rows affected"?

0

I'm not quite sure... when I go to Users, the user that I'm using, these two items are checked: public and db_owner. Then when I go further to Permissions, nothing at all is checked. I tried checking Delete from the column for the particular table that I'm trying to delete data from but when I click save and go back, it doesn't look like it's saved because there's no check marks again. I'm doing all of this with ASP.NET Enterprise Manager. I hope I'm explaining it to where it's making some sense.

0

I don't know what to tell you if you aren't getting any error messages. I've never used .Net Enterprise Manager, so can't give you specifics. Can you update information in those rows? BannerId is an int, right?

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.