0

Hi to all! I am using sql server 2008 enterprise edition. My instance name is "saboor-pc/ SQLSERVERENT". I am using this server for many months and i am satisfied but today an unexpected error occured when i clicked on "connect" button in sql server management studio. The error was: "Cannot connect to
SABOOR-PC/MSSQLSERVERENT
A connection was successfully established with the server, but then an error occured during the pre-login handshake(provider: SSL Provider, error:0 The message recieved was un expected or badly formatted)(MicroSoft SQL Server)"
above is the error statement in double quots. Please guide me how can i solve this error because i have to do v important work on database which i have created in this server.

5
Contributors
7
Replies
55
Views
1 Year
Discussion Span
Last Post by Alec_2
0

Have you tried restarting the server? Did your system crash while SqlServer was running? You also might run a disk check to see if you have disc / file system problems.

0

RudyM , I have tried "netsh Winsock reset" but my problem is not solved . But i have installed Eclipse as new software in my system.

Rubber Man I have tried to restarted my problem but my server does not restared and again that error message displayed which I showed above. My system did not crash ever using SQl server.

0

Hello! actually i wrote above statement ("sorry, restarted my server not problem ") to correct my sentence in previous reply. My server connection problem is not solved yet. if any person have any technique to solve this then please reply.

0

In some installations of SQL Server, connecting to the Database Engine from another computer is not enabled unless an administrator uses Configuration Manager to enable it. To enable connections from another computer:
Open SQL Server Configuration Manager, as described earlier.
Using Configuration Manager, in the left pane expand SQL Server Network Configuration, and then select the instance of SQL Server that you want to connect to. The right-pane lists the connection protocols available. Shared Memory is normally enabled. It can only be used from the same computer, so most installations leave Shared Memory enabled. To connect to SQL Server from another computer you will normally use TCP/IP. If TCP/IP is not enabled, right-click TCP/IP, and then click Enable.
If you changed the enabled setting for any protocol you must restart the Database Engine. In the left pane select SQL Server Services. In the right-pane, right-click the instance of the Database Engine, and then click Restart.

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.