I'm using phpMyAdmin to manage my databases, I have 2 projects that use 2 different database the first one uses 'root'@'localhost' and the 2nd is 'root'@'127.0.0.1' I don't know how i ended up using 2 different server but it was working fine until i tried to edit codes with the 1st project that uses 'root'@'localhost', I was trying to select from a table to be loaded to a DataGridView when an error popped up saying "Host 'hostname' is not allowed to connect to this MySQL server". The 2nd project is working fine. This only happened after I try to create a module for connecting to mysql database since the earlier code for connecting to mysql is written in every form.

I went to the mysql.user table to check if i can edit users and passwords, I tried. But any command that I try to do won't work, after getting back to my databases, when i try to select anything phpMyAdmin says "No database selected". After closing and opening it again every single database is all gone.

I don't know where i f'd up. I'm sorry if this is a dumb question to ask I just really need help. I'm already thinking uninstalling and reinstalling wamp and then recreating all the lost database but im still hoping there is another workaround here.

localhost and 127.0.0.1 should point to the same location. 127.0.0.1 is the IP address for localhost, your local machine.

Thank you for the replies! Will these get back my missing databases i tried both nothing happened