0

hello has anyone installed and uploaded phpadmin through dreamweaver. can anyone explain to me how? im a bit stuck

2
Contributors
10
Replies
11
Views
11 Years
Discussion Span
Last Post by sn4rf3r
0

it is this part that i am confused about

"
Now you must configure your installation. There are two methods that can be
used. Traditionally, users have hand-edited a copy of config.inc.php, but
now a wizard-style setup script is provided for those who prefer a
graphical installation. Creating a config.inc.php is still a quick way to
get started and needed for some advanced features.
+ To manually create the file, simply use your text editor to create the
file config.inc.php (you can copy config.sample.inc.php to get minimal
configuration file) in the main (top-level) phpMyAdmin directory (the
one that contains index.php). phpMyAdmin first loads libraries/
config.default.php and then overrides those values with anything found
in config.inc.php. If the default value is okay for a particular
setting, there is no need to include it in config.inc.php. You'll need
a few directives to get going, a simple configuration may look like
this:
<?php
$cfg = 'ba17c1ec07d65003'; // use here a value of your choice
$i=0;
$i++;
$cfg[$i] = 'cookie';
?>
Or, if you prefer to not be prompted every time you log in:
<?php
$i=0;
$i++;
$cfg[$i] = 'root';
$cfg[$i] = 'cbb74bc'; // use here your password
?>"

0

What are you confused about?

you need to have mysql up and running on a machine lets say its localhost and you have username john with a password of password.

//url for this machine
$cfg['PmaAbsoluteUri'] = 'localhost';
$cfg['Servers'][$i]['auth_type']     = 'config';    // Authentication method (config, http or cookie based)?
$cfg['Servers'][$i]['user']          = 'john';      // MySQL user
$cfg['Servers'][$i]['password']  = 'password'

After that every thing should be fine, you might need to edit a vhost file or put the entire phpmyadmin into your webroot (security risk) in order for it all to work fine.

As for using dreamweaver, you should be able to do the same thing with a real ftp client, with much less hassle. Its up to you.

0

haha everything really. i could do it without myphpadmin but ive been told it makes life alot easier. ive uploaded all the files to my server via dreamweaver. now i have to create a file called config.inc.php but not sure what they mean by editing it
i have mysql on my host ftp
id prefer to be prompted for my password every time i log in so do i just create a file with
<?php
$cfg = 'ba17c1ec07d65003'; // use here a value of your choice
$i=0;
$i++;
$cfg[$i] = 'cookie';
?>
and name it config.inc.php and upload it with the rest of the files installed in the directory?

0

well ive tried that code but that comes up with a blank page. still its not an error so must be getting close. please help

0

there should be a config.inc.php in the directory, edit that. By edit I mean open it up in dreamweaver and change the values to whatever they need to be for your set up. all you need to do is select cookie type, set the username, password, and url.

Dont worry about the blowfish hash.

0
<?php
/* $Id: config.sample.inc.php,v 2.1.2.2 2006/08/28 08:14:14 nijel Exp $ */
// vim: expandtab sw=4 ts=4 sts=4:
/**
 * phpMyAdmin sample configuration, you can use it as base for 
 * manual configuration. For easier setup you can use scripts/setup.php
 *
 * All directives are explained in Documentation.html and on phpMyAdmin 
 * wiki <http://wiki.cihar.com>.
 */
/* 
 * This is needed for cookie based authentication to encrypt password in 
 * cookie
 */
$cfg['blowfish_secret'] = ''; /* YOU MUST FILL IN THIS FOR COOKIE AUTH! */
/* 
 * Servers configuration
 */
$i = 0;
/* 
 * First server
 */
$i++;
/* Authentication type */
$cfg['Servers'][$i]['auth_type'] = 'cookie';
/* Server parameters */
$cfg['Servers'][$i]['host'] = 'localhost';
$cfg['Servers'][$i]['connect_type'] = 'tcp';
$cfg['Servers'][$i]['compress'] = false;
/* Select mysqli if your server has it */
$cfg['Servers'][$i]['extension'] = 'mysql';
/* User for advanced features */
$cfg['Servers'][$i]['controluser'] = 'pmausr';
$cfg['Servers'][$i]['controlpass'] = 'pmapass';
/* Advanced phpMyAdmin features */
$cfg['Servers'][$i]['pmadb'] = 'phpmyadmin';
$cfg['Servers'][$i]['bookmarktable'] = 'pma_bookmark';
$cfg['Servers'][$i]['relation'] = 'pma_relation';
$cfg['Servers'][$i]['table_info'] = 'pma_table_info';
$cfg['Servers'][$i]['table_coords'] = 'pma_table_coords';
$cfg['Servers'][$i]['pdf_pages'] = 'pma_pdf_pages';
$cfg['Servers'][$i]['column_info'] = 'pma_column_info';
$cfg['Servers'][$i]['history'] = 'pma_history';
/* 
 * End of servers configuration
 */
/*
 * Directories for saving/loading files from server
 */
$cfg['UploadDir'] = '';
$cfg['SaveDir'] = '';
?>

this is the file. how do i know what cookie type to select
thanks for your help so far

0

you did select the cookie in the auth type variable.

Turn on all errors if you are still getting a blank page. Also make sure that you have set up a vhost and/or your httpd.conf correctly IE DocumentRoot, ServerName, etc

0

yeah, youre never going to get any content on that page, does it echo anything oout? no its a config file, try index.php

0

also, you should install phpmyadmin in a sub directory of your webroot. /db or something

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.