0

OK everyone, this is probably gonna be a stupid question, so brace yourself. I'm brand new to all this. I'm really not having a literal problem, but it's driving me nuts because I don't know what it is.

Forgive me if something like this has been discussed before. I just have no idea how to even find an answer without someone telling me. I've gone through the documentation, the beginners section says nothing of it, nor does the tutorial. I even tried Google, etc. Here's the thing. What is that little symbol in IDEAL when you press enter? It looks like a music notation.

Thanks a lot everyone,

Sincerely,
Sanoski

3
Contributors
9
Replies
10
Views
9 Years
Discussion Span
Last Post by ZZucker
0

Anyone????? Here is a picture of what I mean. Surly someone knows what this is. It's driving me nuts!!!

Attachments IDEAL_mystery.JPG 32.33 KB
0

oops.... I was really tired when I wrote that. I mean IDLE. The GUI editor included with python. I'm running Win-XP home (if that matters)

0

To tell you the truth, I have never seen those before in IDLE and I run XP. Looks like you are showing the editor window. Are you running IDLE that comes with Python25?

0

Yea, I downloaded the latest version of Python from Python.org

Running the Python Command prompt confirms: Python 2.5.2

Everything works fine. But when I press enter to move down to the next line, one of these stupid symbols pops up, and I have to delete it. I tried running a program without deleting them, and it still works. Apparently Python ignores them, but it really makes my code look crappy, and it's such a hassle having to delete them every time I press enter. Sometimes they wont show up. If I press enter a bunch of times it skips a few. But as soon as I pause, and then I press enter; sure enough another one of these mystery notations pops up. It's extremely frustrating.

0

And yes, I am in a text editor. I simply open up the IDLE GUI editor, I go up, press 'File' then 'New' -- and then I write my programs in that new window.

0

OK, here is an update. I changed the font, and the symbol changed from a unusual music looking thing, to a little square. I went through all my fonts, and I can't get it to not show something. Either it shows a tiny square or it shows that symbol above. I'm at a loss here. Haven't a clue what is going on.

0

It looks like you are visualizing new line characters, actually empty lines. There is got to be an option setting somewhere in IDLE where you can turn this off.

I don't use IDLE, but mostly the PyScripter IDE.

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.