When running GWBasic on one of my computers Alt/Enter works perfectly at minimising the Basic window, but on my other computer it has no effect at all. Both computers are running WinXP. How do I train Computer 2 to respond?
Thanks

grow up and stop using a 20 year old "programming" language hacked onto an operating system it doesn't belong to.

Thanks for your help(?). I rather thought that it was fairly grown up to wonder why two apparently identical systems behaved differently. Aged 73, with BSc, MSc, PhD and DSc degrees, and with 180 scientific publications in professionally edited and refereed journals to my name, I find that this approach has served my fairly well in the past.

Comments
you sure told him. Jwenting can be very condescending.

With Windows, there is no such thing as 'identical systems', alas.

Because of its age GW-BASIC has some difficulties handling the hardware/software changes that have occurred beneath it. XP's DOS emulator is actually rather weak, and is known to goof in weird spots.

A good spot to start when dealing with Windows directly is this page: Running GW-BASIC under Windows. (The whole site is actually pretty good.) The recommendation is to have your GW-BASIC programs set up to start by turning off as much as the new-fangled Windows stuff as possible, and open directly in a full-screen mode. (Of course, Vista will not play fair no matter what you do to the Windows environment.)

There is also a known bug with Compaq systems that needs to be patched. (But I don't know if this applies --it has been years since I have had to mess with a Compaq PC.) Enable Compaq PCs to Run QBASIC Programs

The other option is to run it under a good DOS emulator. (That is, not the one that comes with Windows.) I recommend DOSBox. There are others.

Good luck!

Thanks for your help, time and patience Duoas. You have given me much to play with.

This article has been dead for over six months. Start a new discussion instead.