We're trying to get our C# program to work on linux. We just loaded into Mono, and it compiles fine but the form doesn't appear. Anyone know what? Does it have something to do with it being a "windows form"?

I have gotten Windows Forms to work under mono before.

Are you using any of the winapi as well?

Take a look at the mono migration analyzer, it should most likely tell you what could be wrong.

http://www.mono-project.com/MoMA

Have you confirmed mono is actually working first?

yes mono is working.
I ran the app through MoMa and it said something about one of our methods not being supported but no big deal. Just a simple cursor_clip.

But we still get compile errors that don't show up in MoMa. It has something to do with the program using system.

Here's our code if anyone with linux experience gets a chance to try it in mono.

Compile errors?

I thought your first post said you didn't get any compile errors. Are you getting any error or just the form doesn't show up?

now we're getting compile errors for some reason. I don't know why

Feel free to post the errors if you need assistance with them.

Once it is all straightened out with them, let me know what the result is on mono.

I get two parsing errors (CS8025).

Whats the text that goes with? Whats the lines it barfs on?

They're both on Line 1

Using System

It says one is associated with Form1.resx and the other is Resources.resx

Is there no ";" on the end of that line?

There is

Think it might be an issue with the encoding

try changing a line of code on the linux machine and resaving

i don't think it is properly reading the utf(i think) encoding

Created the hello world program and it ran fine

OK thats a good thing.
So, that boils down to the files.. How did you get them on your linux box? scp? ftp? samba?

If they still have windows line ends that could do it

I transfered them via flash drive

see if you can download a package called dos2unix

depending upon what distro you are on, you can do something like this
apt-get install dos2unix

you can run it to convert your windows files in to linux encoded

it seems like it can't read the files properly

failing that open it in vi and do search and replace on ^M (ctrl+V,M) and remove them

Ok itÅ› working now in Ubuntu. I was trying Fedora earlier.

Is there a way to modify the form from Mono? I see the Form1.designer.cs but it brings up the code, not the layout. Do our forms need to be designed in visual studio and then imported to Mono? Or is there a form designer available?