..bescause it is not a design time package" is shown first time I try to load a project that contains a TTable.
I have to let system remove my declaration of TTable. Then I can create a new TTable, with the same name and my application works.
Next time I start D2007 and open my project same thing happens. I have tried to install D2007 again with same result.

If I start D2007 and create a new project with just a TTable on a form I get the same message. Then if I openmy other project (which contains TTable) it works fine. Something seems to be set when I get that message.

I'm running two machines and in my desktop it works fine, without this problem. There are three adortl100 files with identical dates and times in both machines.

Any ideas?

Attachments Image1.jpg 14.46 KB

Hmm sounds like its added the wrong library to the project thinking its a design package.. thats very clearly a runtime one. Remove it from the defaults. (just uncheck it)

I don't understand "Remove it from the defaults. (just uncheck it)".

If you mean Project - Option - Packages - and then untag "Codegear BDE DB Components" they are tagged in my both computers. Also my BDE objects disappear from the tools menue.

Even if I copy .dpr and dproj files from my working computer it doesn't work. So it must be something wrong with the installation of D2007.

no that removes the run time..

Under default options - eg with no project open look at the packages.. one of them will either list the file specifically or look through the filenames to find it.

correction that removes dev version not run time, you need to look for the rtl one thats in there.

The file isn't there and there is no rtl files what so ever, just bpl files.

bpl is the extension at the end, much myfile.txt is .txt at the end, somewhere thers a *rtl.bpl file

The file is present in \System32 but I can not find any reference to it in D2007.

Hmm, something is, is it only if you open a specific project, or even if you do new project?

This article has been dead for over six months. Start a new discussion instead.