Hi All,
I am working on the Nohau Emulator with a POD having 68HC11E9 controller in Expanded mode. It was working fine with my target board a couple of months back, but now a days I am facing a problem with it.
When I do external memory mapping in the Seehau settings, I see that the data at externally mapped locations show a fixed pattern of 0x00 to 0xFF data for the whole range. I am doing mapping for the locations 0x0000-0x0FFF, 0x1000-0x1FFF, 0x2000-0x2FFF. This is RAM of my Target board. If I try to write something forcefully at these locations, Seehau software doesnt allow me to do so. Because of such problem, some of desired functions are not getting executed in the firmware. This happens even when the target board is not connected. I tried to use the different set of Emulator i.e. HSP box and POD but that is also showing the same problem. I uninstalled and reinstalled the software but was still having the same problem. I also tried with using another PC thinking that it might be a PC or port problem, but that was also of no use. The problem was still there.
Please let me know if anybody has worked on Nohau Emulator and observed such behavior. Please tell me what you did to solve the problem.

Thanks,
Suvrat.

Have you asked Nohau for support?

These bits of kit are not exactly cheap, so it's worth investing in the support which comes with them.

Hi Salem,
Thanks for giving time to read and replying. Yes you are right, I have asked Nohau support. Our local Nohau support person (Pune,MH,India) is trying to resolve but he is also facing a lot of problem to understand the problem and can not resolve it on his own. He is communicating with the US support team for solution but I think it will take some more time and it may be needed to send emulator to them in US or so. I thought by that time parallely I can take help of tallented and supportive people discussing on forums. Just in case if anybody has faced same issue and has solved it, can help me.

I'm not familiar with that product but am familiar with various emulators, etc.
Same target, same emulator?
Check for loose connections on the target. Double check your pins! Your target has all voltages it requires? Verify that!
Did the target sustain an electrical discharge? The idea is look for a bent pin, something loose, or blown. Corrosion!

Did you use unleaded solder? Look for cat whiskers!

Something could have happened to either unit while in storage. Was the emulator used for some other project since, and so miss configured?
Does it act like its downloading the kernel/app code but doesn't seem to run? If so, does it actually run but very very slowly? Check for a damaged xtal. Crystal's and Oscillators can get pretty finiky if the board they are attached to gets dropped!

Edited 7 Years Ago by wildgoose: n/a

I agree with wildgoose, this stands a good chance of being a local hardware problem.

Try the emulator with known good hardware.

Are there any advanced diagnostics for the probe, more than what would be quickly executed at startup?

Do some research into ESD, and adopt some safe practices
http://support.necam.com/mobilesolutions/hardware/esdhandle.asp
Devices seldom get fried in a single exposure, but damage is cumulative.
Some trivial event repeated often enough will render your board dead.

This article has been dead for over six months. Start a new discussion instead.