First let me say I know absolutely nothing about Python. All I know for sure is that I own the PC game Vampire Bloodlines and I am getting a runtime error. I have researched online and have read that if you have an older version of Python the game will not run and will give this error.

In my research I have seen where it is adviseable on the one hand to delete the Python entries in the registry. Ok, that's scary, since I have XP and it came with Python already installed.

Also I read that Python could be upgraded and it would use an alternate registry entry and not cause the conflict with the game. Now I could use some advice please on selecting which Python upgrade to use. Because this has me completely confused.

Thank you so much for any assistance or suggestions. :)

Recommended Answers

All 7 Replies

What version of Python does your game recommend?

From what I read it recommends version 2.3 or 2.4. Would there be a reason why I would need the Python installed as I am not a programmer or are other programs dependent upon this? :cheesy:

It sounds like your game is simply a precompiled set of Python files rather than an executable (.exe) file. In this case you need the Python interpreter present on your computer.

The interpreter isn't very large, but the installer download is a package with some extra files you normally wouldn't need. I don't know of just a runtime package.

I find it strange that your XP box had an older version of Python installed already. Microsoft most likely looks at Python as an evil competitor.

If you are familiar with removing old programs, you should uninstall the old version first to be on the safe side. Hopefully it is listed under Python-2.1 or whatever.

Go to the website and download version 2.4. It comes as a self-installing file called python-2.4.1.msi.

I have the 2.1 version and quite honestly I am assuming it came with XP, as I have never heard of Python until I tried running this game. Thanks, I'll go delete the 2.1 and then get the 2.4.1.msi and see what happens...*crosses fingers*

Ok downloaded and installed the 2.4. I guess I will absolutely give up on this game now. I get the same error, obviously this game hates me and my PC. :cry:

Thank you very much for your help and suggestions Vegaseat.

I heard that python 2.6 is the one of the best versions. Upgrade to this and it'll probably work. When was the game made. If it is really new (in the last year or two) then you may need V3.1.

When was the game made. If it is really new (in the last year or two) then you may need V3.1.

If you had paid attention, you could have seen that this thread is 4 years old. :icon_wink:

Be a part of the DaniWeb community

We're a friendly, industry-focused community of developers, IT pros, digital marketers, and technology enthusiasts meeting, networking, learning, and sharing knowledge.