when I try to compile my project file in devcpp I get the following error:
I tried googling but nothing seems to help when i tried them.

CreateProcess((null), C:/cygwin/bin /sh.exe -c "g++.exe -c test.cpp -o test.o -I\"C:/Dev-Cpp/lib/gcc/mingw32/3.4.2/include\" -I\"C:/Dev-Cpp/include/c++/3.4.2/backward\" -I\"C:/Dev-Cpp/include/c++/3.4.2/mingw32\" -I\"C:/Dev-Cpp/include/c++/3.4.2\" -I\"C:/Dev-Cpp/include\" ", ...) failed.

Access is denied.

C:\Users\dedl\Desktop\SAIM\SAIM3\OpenGLGLUT\Makefile.win [Build Error] [test.o] Error 5

yes all my programs so far compiled properly. Only for this one project I used OpenGL Glut Libraries and this error came up.

by the way this is the compile log....dont know what is wrong...

Compiler: Default compiler
Building Makefile: "C:\Users\Gabriel\Desktop\SIM\SIM-Year3\CSCI336\OpenGLGLUT\Makefile.win"
Executing make...
make.exe -f "C:\Users\Gabriel\Desktop\SIM\SIM-Year3\CSCI336\OpenGLGLUT\Makefile.win" all
g++.exe -c test.cpp -o test.o -I"C:/Dev-Cpp/lib/gcc/mingw32/3.4.2/include" -I"C:/Dev-Cpp/include/c++/3.4.2/backward" -I"C:/Dev-Cpp/include/c++/3.4.2/mingw32" -I"C:/Dev-Cpp/include/c++/3.4.2" -I"C:/Dev-Cpp/include"

process_begin: CreateProcess(NULL, C:/cygwin/bin /sh.exe -c "g++.exe -c test.cpp -o test.o -I\"C:/Dev-Cpp/lib/gcc/mingw32/3.4.2/include\" -I\"C:/Dev-Cpp/include/c++/3.4.2/backward\" -I\"C:/Dev-Cpp/include/c++/3.4.2/mingw32\" -I\"C:/Dev-Cpp/include/c++/3.4.2\" -I\"C:/Dev-Cpp/include\" ", ...) failed.
make (e=5): Access is denied.

make.exe: *** [test.o] Error 5

Execution terminated

Try deleting all the compiler-generated files from your project directory and the exe too, then recompile. Also check if there is another instance already running of the program you are trying to compile. Do this by looking at Task Manager.

ok so my folder contains only src code and project file(.dev file) there are no other instances. But it still gives the same error. When i googled, most errors that came up were Error 1 but my compiler gives Error 5 with Access Denied.

Or ditch dev-c++ as your IDE and go with something like code::blocks.
dev-c++ is no longer maintained, and is known to be somewhat buggy.

after trying so many times i figured that it is the makefile.win file which causes the problem. I compiled the source code without making a project and it works fine.

This question has already been answered. Start a new discussion instead.