I am trying to compile my project in VC++ Express Edition and get the error below. The project did compile fine before I reinstalled XP windows.
But now when I have installed everything again, I receive this error.

I dont understand what this can mean ?
When clicking the errorline "The system cannot find the path specified", Form1.cpp is opened and points to:
#include "stdafx.h"

I do dind both these files in the Form1 folder, both (stdafx.h and stdafx source)

1>------ Build started: Project: Form1, Configuration: Debug Win32 ------
1>.\Form1.cpp(3) : fatal error C1093: API call 'ImportFile' failed '0x80070003' : ErrorMessage: The system cannot find the path specified.
1>Description: The system cannot find the path specified.
1>HelpFile: complib.hlp
1>Build log was saved at "file://e:\Documents and Settings\Jen\My Documents\Visual Studio 2008\Projects\Form1\Form1\Debug\BuildLog.htm"
1>Form1 - 1 error(s), 0 warning(s)
========== Build: 0 succeeded, 1 failed, 0 up-to-date, 0 skipped ==========

Edited by Jennifer84: n/a

8 Years
Discussion Span
Last Post by Jennifer84

The name "stdafx.*" is the name that VC++ gives to its "precompiled headers"-related files. Some people have trouble with them, some don't. I don't know why. It seems your O/S rebuild introduced the environmental situation that causes the issue.

Have you added anything to "stdafx.h" or "stdafx.cpp"? If not, disable the "precompiled headers" option for the project and exclude the files from the project.
How to disable:

  1. Right-click your project's name in the solution explorer and select "properties".
  2. In the dialog that appears, expand the "C/C++" node in the tree on the left.
  3. Select the "precompiled headers" node of the "C/C++" tree
  4. On the right, set "Create/Use Precompiled Header" to "Not Using Precompiled Headers"
  5. Click "OK" to exit the dialog.

Edited by Fbody: n/a


Yes in somehow that did solve the problem. I also heard that this header could have some troubles.

Thanks for this help.

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.