I am trying to set up the GUI Library FLTK but cannot find a way to set it up for MSVC++ 2010 Express. I looked on Google but failed to find any tutorials on doing this. I also tried CMake but ended up with an error in CMake and an empty solution :(. Does anyone know how to do this or a tutorial that tells how to do this?

What was the error in CMake? There may have been some component missing that you needed. Also, the CMake 2.8 (EDIT: Seems to be the most current) only has entries for MS compilers up to VC++ 2008 which may also be a problem. VC++ 2008 Express is still available I think. I don't know for sure but you could probably compile them on 2008 and use them in 2010.

Edited 6 Years Ago by jonsca: n/a

here's the error message, and it has entries for Visual Studio 10 (i think the same as 2010), which works on the Express Editions:

CMake Error in src/CMakeLists.txt:
Cannot find source file "Fl_Abstract_Printer.cxx". Tried extensions .c .C
.c++ .cc .cpp .cxx .m .M .mm .h .hh .h++ .hm .hpp .hxx .in .txx

Edited 6 Years Ago by Buolbear4444: n/a

it has entries for Visual Studio 10 (i think the same as 2010), which works on the Express Editions:

Yeah, I just went back and checked it's at the front of the list instead of at the end. Apologies.

Which version of the source did you download, I'll try it out.

I also just ran across this on www.cmake.org, I don't know if it's pertinent:

Visual Studio 2010 Express: Visual Studio 2010 Express came out after we made the release of 2.8.1. There is an issue with the way the IDE executable was found in 2.8.1 that will prevent projects from being created. To fix this issue, Modules/CMakeVS10FindMake.cmake needs to be replaced after you run the installer. It should be replaced with this file: CMakeVS10FindMake.cmake

I got the same error. I went to look for that file by hand but it doesn't seem to be there. There's a note in one of the logs http://www.fltk.org/articles.php?L982 that this class was renamed so it's probably causing problems. You may have to update the CMake lists by hand but I have never done that myself. I didn't try it but the latest 1.1.x (stable) releases should have less issues.

This article has been dead for over six months. Start a new discussion instead.