Pyscripter seems to be hard coded to use versions 2.3 to 2.6, and skips over 2.7, moving on to 3.0 and 3.1 - niether which seem to play nice with Unix data.

Considering 2.7 is Python.org's current stable release, does anyone know how to get Pyscripter to use it? I've tried all of the various IDE's, I think Psycripter is the best hands down to me.

Secondly, anyone using it with an external debugger?, can't seem to get that to work, says the external debugger is not installed even though it is. Can't stand how Pyscripter hangs while dubugging. When Tk has an error and needs to be shut down, Pyscripter shuts down too. Ugh!

Pyscripter version 2.0 is out now,support python 2.7.

Try pyscripter v2 from pyscripter.googlepages.com

Pyscripter seems to be hard coded to use versions 2.3 to 2.6, and skips over 2.7, moving on to 3.0 and 3.1 - niether which seem to play nice with Unix data.

Considering 2.7 is Python.org's current stable release, does anyone know how to get Pyscripter to use it? I've tried all of the various IDE's, I think Psycripter is the best hands down to me.

Secondly, anyone using it with an external debugger?, can't seem to get that to work, says the external debugger is not installed even though it is. Can't stand how Pyscripter hangs while dubugging. When Tk has an error and needs to be shut down, Pyscripter shuts down too. Ugh!