I have to use a software package written in c with many different files.

It has an executable file with a variable -

cc=/usr/bin/gcc

cc is later used in that file to compile other files present in the software.


wenever i try to run this file I get an error command not found. How do I fix this?
my gcc is located in the above directory only.
M using ubuntu 9.10

Sure.. Here's the whole code..Since its not really any lang (I think so :-)) so m putting it in C code tage...

CC = /usr/bin/gcc
GCCFLAGS = -c -Wall
ROOTDIR = .
SRCDIR = $(ROOTDIR)/src
OBJDIR = $(ROOTDIR)/obj
VPATH  = src:obj:include

OBJ = $(OBJDIR)/assess.o $(OBJDIR)/frequency.o $(OBJDIR)/blockFrequency.o \
      $(OBJDIR)/cusum.o $(OBJDIR)/runs.o $(OBJDIR)/longestRunOfOnes.o \
      $(OBJDIR)/serial.o $(OBJDIR)/rank.o $(OBJDIR)/discreteFourierTransform.o \
      $(OBJDIR)/nonOverlappingTemplateMatchings.o \
      $(OBJDIR)/overlappingTemplateMatchings.o $(OBJDIR)/universal.o \
      $(OBJDIR)/approximateEntropy.o $(OBJDIR)/randomExcursions.o \
      $(OBJDIR)/randomExcursionsVariant.o $(OBJDIR)/linearComplexity.o \
      $(OBJDIR)/dfft.o $(OBJDIR)/cephes.o $(OBJDIR)/matrix.o \
      $(OBJDIR)/utilities.o $(OBJDIR)/generators.o $(OBJDIR)/genutils.o

assess: $(OBJ)
	$(CC) -o $@ $(OBJ) -lm

$(OBJDIR)/assess.o: $(SRCDIR)/assess.c defs.h decls.h utilities.h
	$(CC) -o $@ -c $(SRCDIR)/assess.c

$(OBJDIR)/frequency.o: $(SRCDIR)/frequency.c defs.h externs.h
	$(CC) -o $@ $(GCCFLAGS) $(SRCDIR)/frequency.c


$(OBJDIR)/generators.o: $(SRCDIR)/generators.c defs.h externs.h utilities.h \
        config.h generators.h
	$(CC) -o $@ $(GCCFLAGS) $(SRCDIR)/generators.c

clean:
	rm -f assess $(OBJDIR)/*.o

rebuild: clean assess

M getting errors for all these 3 variables
CC = /usr/bin/gcc
GCCFLAGS = -c -Wall
ROOTDIR = .

In ROOTDIR i tried putting the path in which my files/folders exist but still got the same error for all lines: line i: CC command not found.

Its just the makefile from the software package...

Software is available here for reference : http://csrc.nist.gov/groups/ST/toolkit/rng/documentation_software.html

>>CC = /usr/bin/gcc

try removing the white space on that line

done that already.. I tried with space without space...i also tried CC=gcc.
Still the same...:(
Even tried putting it in " " .

Are you trying to execute the makefile? What about just typing make at the command prompt?

Hey it worked!!! thanku so much :)

This question has already been answered. Start a new discussion instead.